Update won't download...can't uninstall Silverlight


  • That just about says it.  Using Vista Home Premium, latest update stalls and won't download.  I want out of Silverlight, but can't even uninstall it using Control Panel uninstall.  Any suggestions?

    Tuesday, May 20, 2008 1:26 PM


  • I finally was able to get rid of Silverlight by doing a System Restore to a date before it was installed.  Give that a try.


    Wednesday, May 21, 2008 4:53 PM

All replies

  • I have a similar problem.  I installed version 1.0.30109.0 some time ago.  Now, I keep getting prompted to install the upgrade (version 1.0.30401.0).  However, while the upgrade downloads fine, it fails to install.  The "help" that I have found by searching suggests that I manually uninstall the older version.  When I go into Add/Remove Programs applet, it cannot uninstall the program.  

     Apparently, "silverlight.msi" was placed in a directory in c:\temp\... that has since been deleted as part of the disk cleaning that I routinely perform on my disks.  Now there appears to be no way to remove the program.  I have tried limited registry edits and manually deleting files, but I do not seem to be able to find the combination that will allow me to install the newer version or reinstall the older one.  (My registry edits have been limited to removing the 'uninstall' key associated with this program, as I am not comfortable making more drastic changes without guidance.) I have also tried a couple of freeware programs that promised to be able to remove the program without success, too.

    I would appreciate any help that someone could offer. 

    Wednesday, May 21, 2008 12:11 PM
  • Same Problem Here!!  I've sent 3 emails to Microsoft Techs but so far no response.  The popup window says "The installation source for this product is not available.  Verify that the source exists and that you can access it.".

    Now how the heck can we do that??



    Wednesday, May 21, 2008 4:32 PM
  • I finally was able to get rid of Silverlight by doing a System Restore to a date before it was installed.  Give that a try.


    Wednesday, May 21, 2008 4:53 PM
  • Thanks for the response.  I appreciate it and I will keep it in mind.

    However, I purchased and installed several applications since 'silverlight' first installed last year.  I am hoping for another solution so I do not have to reinstall all that other stuff. 

    However, I will go back to my update history and see if I can figure out when it first installed so I know how much stuff would need to be reinstalled after the rollback. Thanks again!

    Wednesday, May 21, 2008 9:02 PM
  • Hey, I solved my problem.  I found, downloaded, and installed Windows Installer Cleanup Utility.  I ran it and selected "Microsoft Silverlight" from the list of installed programs.  I hit the 'remove' button and it removed Silverlight. 

     I then went to the Silverlight website and downloaded the version that was failing to install (version 1.0.30401.0).  It installed successfully, is running correctly (so far), and best of all, I am not plagued by continual messages to install an update that refuses to install.  I hope this alternative will help others.

    Friday, May 23, 2008 12:28 PM
  • Thanks a bunch.  I did the same and Silverlilght is GONE!


    Friday, May 23, 2008 4:03 PM
  • I tried the Clean up utility and it was deleted off the registry but I still had problems logging into sites that had Silverlight, especially  I couldn't even get the main page to load up!  Finally got ahold of v.2 beta to load up on my system again.  It loaded up but it doesn't show up on my system anywhere.  Not in the registry nor the Add/Remove screen.  I can see the folder under Program Files but it doesn't seem to be loaded up; although I still can't get into any of the sites.  Reinstalled again and still nothing.  Ran Cleanup and it isn't on the list.  So lost and confused!  Help!!!  Crying

    Wednesday, May 28, 2008 12:02 PM
  •  Using XP, can not install silverlight 2.0

    Thursday, October 16, 2008 3:58 PM
  • I've searched for this Utility but have been unable to find it.  Can you enlighten me as to the search options to use to find it.  I REALLY want to get rid of Silverlight because I have no use for it and I certainly don't need the aggravation of this 'update' constantly trying to install and won't.  Thanks for your help.

    Saturday, October 18, 2008 3:27 PM
  • Today, I went thru an uninstall of Silverlignt and VB on a Vista pc.  THere are two things that I ran into that may be of some help to you. 

    Uninstalling VB  -  I had to uninstall MSDN.    I couldnt get get rid of VB untill I did that, the Setup program kept crashing.

    While installing some things, the installs would freeze.  I think this also occurred with some uninstalls.  Regardless, the process MDM.exe was the problem.  Try killing this process and see if it helps.

    FYI:  After uninstalling all the bad, I reinstalled VB 2008, then went to the new Silverlight 2 webpage and installed.  All went pretty smoothly.  I have  already created a test Silverlight C# project, added some code and tested it.  All seems well.

    Saturday, October 18, 2008 9:46 PM
  • I have done 2 system restore operations to restore poiSuper Angrynts before I installed Silverlight with no effect.  I really need some help, this program is taking up a lot of my memory and I don't have that much to start with.  Man, has it ever slowed my computer down.  Super Angry

    Thursday, April 23, 2009 2:02 PM
  • I think you need to open a new post for your problem.  Include information like operation system, memory,etc.  THe more info you put in the better.  As is, the only thing you have said is that you have some resotres, which isnt helpful.

    Also include any errors yoru getting.  You will probably get better responses that way.

    Visual Studio needs a fair amount of memory.


    Thursday, April 23, 2009 4:07 PM
  • Windows Install Cleanup Utility

    try it!

    Tuesday, May 12, 2009 4:49 PM
  • The same thing has happened to me.  I tried the Clean Up Utility.  It removed SL 3 from it's list, but got an error during the process (I'll try to post the error text tomorrow- I have it written down at the office).  Now I guess I might be looking at messing with teh registry, which i dread.  Did you ever find a good solution to this issue.

     What is really scary to me is that this seems to be a somewhat common problem.  We already have one SL 1.1 app in production and have had multiple users report similar situations.  We are now working on a re-write of our flagship LOB application in SL 3, and Iam facing the situation myself.  I was hoping this was something that had been worked out in the earlier versions.

     **** EDIT **** I finally found something that worked for me.  I found directions for "manually" removing SL here:

    When I got to the part where i was supposed to delete the SL prpogram files folder, I was unable to do so.  I proceeded to attempt to install the runtime from this site.  The install seemed to complete successfully, but SL apps still wouldn't render for me at that point.  However, I was then able to uninstall via Add/Remove Programs (the way it should be).  This seemed to fully uninstall SL.  I then installed from this site one more time, and things seem to be working now.....finally.

    Unfortunately, now I need to document this for our support staff so they can help out our customers who experience this sort of thing.

    Thursday, October 08, 2009 9:11 PM
  • Attn:    l.pttrsn

     Thanks a ton, this solved my problem instantly!

     My issue was a little different. Mine was related to my firewall, I think that I banned the Silverlight updater from leaving my network because I didn't recognize the program and then instead of investigating when I had a minute I totally forgot about it. For many many many freaking months I've been annoyed by these failed installs but didn't really hurt that much since I generally browse with Firefox.

     Anyway, thanks again l.pttrsn!


    Thursday, December 31, 2009 4:18 PM

    Saturday, January 02, 2010 10:35 PM
  • I tried this method of yours and it worked.

     Thank you for posting this.

    Sunday, January 24, 2010 11:10 AM
  • Thank you, MennoMan47d.  Your tip worked for me.  Your post should be the recommended solution.

    Thursday, December 16, 2010 8:33 PM
  • i solve the problem too, by following your method, tks a big hug

    Friday, December 17, 2010 11:00 AM
  • i solve the problem too, by following your method, tks a big hug

    does not works 4 me... can not install last critical patch version from windows update...

    has not worked....

    Friday, December 17, 2010 2:21 PM
  • Thanks  for your response........
    If you are trying to use is on a network resource that is unavailable.
    You can follow that step to uninstall it :
    1. Click =93Start=94
    2. Go to =93Settings=94 =96 Go to =93Control Panel=94 if you have Windows V=
    3. Click =93Control Panel=94
    4. Click (Add or Remove Programs) if you have Windows XP
    Click (Programs and Features) if you have Windows Vista (Wait for
    the list to load, may take a
    5. Now in the list look for =93Microsoft Silverlight=94 to that then Click
    on it
    6. Click =93Remove=94, =93Uninstall=94 (whichever it says)
    7. Then a window should pop up; just follow the instructions to remove
    it from you there...
    8.... There you have it!

    commodity tips

    Thursday, January 06, 2011 2:08 AM
  • I've got close to the same problem, the clean up download doesn't exist anymore and I still can't get silverlight to uninstall

    Friday, March 04, 2011 6:26 AM
  • Same Problem Here!!  I've sent 3 emails to Microsoft Techs but so far no response.  The popup window says "The installation source for this product is not available.  Verify that the source exists and that you can access it.".

    Now how the heck can we do that??



    Friday, April 08, 2011 3:15 PM
  • one time i got help from microfoft guy he took me through process and it worked but it was ages ago i forget but thats our best bet ok maureen-12

    good luck

    Friday, April 08, 2011 3:17 PM
  • how much did that cost you?

    Friday, April 08, 2011 3:18 PM
  • does not works 4 me... can not install last critical patch version from windows update...

    Sunday, April 10, 2011 4:48 AM
  • hi

    what do you mean step 1 and 2 when you say click 93/94 etc etc



    Tuesday, April 26, 2011 5:15 AM
  • Well I had quite another fun Vista adventure. No, not with the Windows Update not working for about a year (resolved), but this time with Silverlight getting all jacked up. The problem once again stemmed from bad or corrupt registry key related issues. I searched the web for a little bit & came across lots of stupidly obvious suggestions from lots of places & people (even on Microsoft sites where supposed tech experts were telling people with issues "Try going to the control panel folder & use programs & features to uninstall through there then reinstall. Really? Good God...) I tried uninstalling that way first or IIRC Silverlight didn't even show up in there. Tried Revo Uninstaller which found a bunch of Silverlight related files around the drive & deleted them. However I still couldn't install a new Silverlight. It would get hung up @ 99% then stop. Before I started making progress with the registry key modifications it would get hung up before the install & say something like "The source you're trying to install from cannot be found, insert disc or choose location" or something. The Microsoft Fix Its did not work but their failure to work pointed me in the right direction.

    One of the 2 or 3 Fix Its I tried displayed an error code about a particular registry key: HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{DFEAF541-F3E1-4c24-ACAC-99C30715084A}. It would say "Could not open, etc., etc., etc., Access Denied." The permissions were all whacked out & I couldn't delete the key manually by right clicking on it then going to delete. For those of you who don't know, click on the start button in the bottom right hand corner, go up to RUN, type in regedit, then hit enter. It will launch the registry editor. As always be careful with registry modification & do make a backup before trying stuff like this. Otherwise u may end up with a non-usable/ seriously corrupted drive or something.

    So I navigated to the key & had to do some tedious work to reassign the permissions & ownership of the key. & should you read this & have the EXACT same issue you will have to go through each of the 8 subkeys & reassign the permissions & owner if they aren't what they're supposed to be. & one of them ("MiscStatus") has yet another subkey called "1.". Go through each one starting at the bottom at the lowest level, right click on the name of the subkey, go to permissions, look up at the top under Group & User Names, & click Remove till there are none left. Then click ADD then type in whatever your user name is that you're logged in with. It took me a while to figure out what my user name is. I don't log in, my computer just starts up. So for me all I typed in was "Yaz," my user name I chose long ago when I 1st got my laptop. Your user name by itself is all you type in. No other characters. I am the administrator so there were no issues. Then underneath I clicked on the 1st box on the left & assigned myself full control over the subkey. Then click Advanced & make sure neither of the 2 inheritable boxes are checked. Click on the Owner tab at the top & make sure an owner is assigned & that it's your login name.

    After doing this for all 9 of the subkeys I was able to just right click on {DFEAF541-F3E1-4c24-ACAC-99C30715084A} & go to delete & IT WORKED! :) Then I finally launched Silverlight installer & it worked with no further problems. Hopefully this helps some people out. There are a lot of dumb, obvious suggestions out there (just like with the Vista Windows Update not working) & it's nice to be able to figure out how to resolve it this time in an hour or two as opposed to about a year last time there was a registry related issue that nothing would fix other than manually deleting the associated bad keys myself that were left behind by all the uninstallers, Fix Its, & other programs & solutions that did nothing but waste more time.


    Mr. Yazen J. Qafisheh

    Sunday, February 26, 2012 10:43 PM
  • There is an option to open your Visual Studio (in my case 2010) and update Silverlight from there.   It seems there are various reasons that versions install or not.  I'm running Small Business Server 2011 which installs its own copy of Silverlight so uninstall is blocked by group policy.  However, it did not deter the install of Silverlight when I ran Microsoft Web Platform Installer 3.0.

    I expect the problem may be that it requires an installation that is not part of the Silverlight package.  Try installing the Microsoft Web Platform Installer Version 3.0 first.  My case is a bit different from upgrade as to get to the Azure site, the install was a requirement but the install that is the default is a version of Silverlight that is less than my current version.

    Saturday, April 28, 2012 12:25 PM
  • hey man you should put the link up on here would have made my life easier

    Saturday, August 18, 2012 10:03 PM