none
Nuget Package manager does not copy depenencies to output RRS feed

  • Question

  • Hello,

    I have a .net standard library which is referencing onto multiple entity framework core packages via NuGet. However when I build it he only copies my own libaries into the output but not the required dependencies which have been added via NuGet.

    I did not find an option (copy locally) like you have when you setup a real reference without that NuGet nonsense.

    Is there a way to force him to copy references into into local folder? It's just a pain in the a** to search for the libs in C:\%User%\NuGet" and copy them manually into the output folder.

    Furthermore I would like to ask if there is a way to teach NuGet to put the references into the solution folder instead of "C:\%User%\NuGet"?

    I normally do not use NuGet but I know that a few years ago he did store everything solution related into the solution folder. I could not find anything in the settings and I did not find a solution in their "documentation".

    Best regards


    Dev86 Technical Blog

    Thursday, August 22, 2019 1:14 PM

Answers

  • Hello,

    There is a open issue on this here

    https://github.com/NuGet/Home/issues/4837

    Try unloading the project, right click on the project, edit. Add the following

    <PropertyGroup>
        <CopyLocalLockFileAssemblies>true</CopyLocalLockFileAssemblies>
    </PropertyGroup>
    Save, reload, build.


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange


    Thursday, August 22, 2019 2:23 PM
    Moderator

All replies

  • Hello,

    There is a open issue on this here

    https://github.com/NuGet/Home/issues/4837

    Try unloading the project, right click on the project, edit. Add the following

    <PropertyGroup>
        <CopyLocalLockFileAssemblies>true</CopyLocalLockFileAssemblies>
    </PropertyGroup>
    Save, reload, build.


    Please remember to mark the replies as answers if they help and unmarked them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.

    NuGet BaseConnectionLibrary for database connections.

    StackOverFlow
    profile for Karen Payne on Stack Exchange


    Thursday, August 22, 2019 2:23 PM
    Moderator
  • Thank you very much.

    Dev86 Technical Blog

    Friday, August 23, 2019 6:34 AM