none
Connect from IIS (BASIC Authentication) to SSAS failed RRS feed

  • Question

  • Hello

    I am trying to connect to SSAS from IIS located in another domain

    I defined one connection using MSMDPUMP without success

    the SQL profiler says that the (failed) connection is "anonymous" although my connection in IIS is defined as "basic" with user name and passport

    I am following the Microsoft docs about "http connection"

    Any trick or idea?

    Thursday, January 23, 2020 5:29 PM

All replies

  • Hi Capitantrueno,

    Thanks for your question.

    >>the SQL profiler says that the (failed) connection is "anonymous" although my connection in >>IIS is defined as "basic" with user name and passport

    Maybe you need to grant data access permission on Analysis Services server side. For more detailed, please refer:

    Grant data access permissions

    Best Regards,

    Will


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 24, 2020 3:15 AM
  • Hello

    Thank you

    I created one role with permissions for the user in SSAS without success.

    I have been following the Microsoft doc that you link

    https://docs.microsoft.com/en-us/analysis-services/instances/configure-http-access-to-analysis-services-on-iis-8-0

    I have read on the web that you don´t have to use the parameter

    Integrated Security=Basic;

    In the stringConnection in order to connect to SSAS from IIS

    But I get network errors like this one:

    Error Code = 0xC10D0008, External Code = 0x00000000


    Friday, January 24, 2020 7:57 AM
  • Maybe: Which client version are u using? Windows 10? I had some serious fights with credential guard feature, which requires "Constrained Delegation"
    Tuesday, January 28, 2020 1:02 PM