none
Port redirection RRS feed

  • Question

  • Hello,

    I have an onpremise webservice that should be accessable via standard https but the port 443 on my public IP is already blocked by another service. My idea is to establish a routing with port translation via azure.

    i.E.: The customer connects to https://"azure-ip:443" and is routed to mydomain-ip:7443

    Can I configure this with azure services?

    Best regards,

    Joerg.


    Best regards, joerg.

    Friday, September 20, 2019 11:45 AM

Answers

  • Hi, 

    In your case, can you make your service listen on port 7443?

    Also from Azure to On-Prem how are you going to connect ? Via Public IP or Private IP 

    I can suggest you to deploy Application Gateway and do the port forwarding to 7443. You can add On-Prem server to the backend pool to Application Gateway as long as you have IP connectivity between Application gateway and the On-Prem server. 

    Reference: https://docs.microsoft.com/en-us/azure/application-gateway/overview 

    Let me know if you have any further questions. 

    Regards, 

    Msrini

    Friday, September 20, 2019 3:34 PM
    Moderator

All replies

  • Hi, 

    In your case, can you make your service listen on port 7443?

    Also from Azure to On-Prem how are you going to connect ? Via Public IP or Private IP 

    I can suggest you to deploy Application Gateway and do the port forwarding to 7443. You can add On-Prem server to the backend pool to Application Gateway as long as you have IP connectivity between Application gateway and the On-Prem server. 

    Reference: https://docs.microsoft.com/en-us/azure/application-gateway/overview 

    Let me know if you have any further questions. 

    Regards, 

    Msrini

    Friday, September 20, 2019 3:34 PM
    Moderator
  • Hi, 

     

    Just checking in if you have had a chance to see the previous response. If this answers your query, do click “Mark as Answer” and Up-Vote for the same.

    Regards, 

    Msrini

    Monday, September 23, 2019 11:34 AM
    Moderator
  • Hi, thank‘s for your information. The Application Gateway seems to be my solution. I just have some problems in configuration, currently the result is 502 bad gateway. It seems to be an certificate issue, I don‘t know exactly which one to use on both configuration points. I have an wildcard certificate for my domain. Or have I to change the hostname? I will test the different options. May be I figure it out, sometime. BR Joerg

    Best regards, joerg.

    Monday, September 23, 2019 4:44 PM
  • You can check the below troubleshooting guide. 

    Reference: https://docs.microsoft.com/en-us/azure/application-gateway/application-gateway-troubleshooting-502

    Regards, 

    Msrini

    Monday, September 23, 2019 5:25 PM
    Moderator
  • Hi,

    Now I got it to work. I've to change in http-settings the host override settings to none and create a custom health check rule to proof the health of my resource against the public hostname of my router.

    BR Joerg.


    Best regards, joerg.

    Monday, September 23, 2019 7:04 PM