Azure B2C authentication with React Native RRS feed

  • Question

  • I`m currently using azure b2c local account authentication on my react native app, but when I try to run it with Facebook`s login I get this error:

    DEBUG: failed to grant token Object {
      "error": "invalid_grant",
      "error_description": "AADB2C90090: The provided JWE is not a valid 5 segment token.
    Correlation ID: 4eb6d39a-eeac-4e2e-ba3b-81615558fd34
    Timestamp: 2019-04-20 23:03:24Z

    The log that it shows immediatly before that error is:

    DEBUG: ReactNativeAD.grantAccessToken: url https://heitortomaz.b2clogin.com/b2a85c6f-a76e-43bc-84f2-ae909d21fef3/oauth2/v2.0/token
    DEBUG: ReactNativeAD.grantAccessToken: body grant_type=authorization_code&client_id=0079eac6-031f-46a4-83c1-e504f8d3b1ac&redirect_uri=heitortomaz.onmicrosoft.b2c.umatchapp%3A%2F%2Foauth%2Fredirect&code=[big code here]&resource=common
    VERBOSE: ADLoginView navigate to heitortomaz.onmicrosoft.b2c.umatchapp://oauth/redirect?code=eyJraWQiOiJjcGltY29yZV8wOTI1MjAxNSIsInZlciI6IjEuMCIsInppcCI6IkRlZmxhdGUiLCJzZXIiOiIxLjAifQ..F-chVCBZ6YXLZIEC.pEIfWirznEhDsmQLy-LsWfDVHyJtGyAmn32HxLyYGIyVm62OauOc4Ppm8zulDSodbVfWUTsG16DyqpsELxPT2LA9RcSJ0PuM9hNBb4yIOqz2UiHlpM1TuqSUM4RBfi9Nvy3oRlTmVV6pH_3mH7WEuqqrgcGpcjXLoHZDeEPu2r4AbdFjkXJ8xyGVNIjJ0jZXJujyIi78vS4MqJ8y6OQ9w2xoh_AdywpoUsmzLl9h624qn97nNULR-D32fInT8bTKqqQMrvlF-MC7mg6222_j0E7rTxmYrXHzp618VGq7JrcRXRTXKtgjjtyuP0NgAAmv_joefOntusvVyCz9-2R6Ez9c8m60mezFL4MyEtNyxnknQBk4r_oB2gOIaygygqNTGJri0rF9V3Rqyp88-oiWsPsDFRsfTa9jhFK05FzbSj1mcJ05cOwEpoVkKxUfKODw4ZeTxTpW8viDzrSq9VDa3tkY5qoYjwZr1C6COaTAz26T6j4xDEhARS3iQaHy_pPzd_6YwRtRj1qsHDjJAmxyObH7zYolBotnfCSC2wlM3FNpBZ8rNRz-bU2PnXe_KOnHJG9AkB3-8xBEHTvN8iVl5AUlq8Sls65Z35_f2w5uXgW059T4xTYkSyB5h5PGYfIWjL_YEA7cj9EPyiEEtJVqTfVgh97FW1Mb89eyWXO3xz6TIAlVmhjNB_qYQDxU3tANcVbpsrjo-TFk7tEGnMcPlK-OHIAA4KOQlX6X533iLx9TPx4.6x09Exym3SVwMkuECp7tHA#_=_

    I`m using react-native-b2c to set up my authentication.

    Actually i`m able to use facebook`s login when I run "run user flow" at azure b2c portal. But I haven`t found anything that help me to fix that bug on my mobile app.

    Someone could help me with that?

    Saturday, April 20, 2019 11:33 PM

All replies

  • actually the library name is react-native-ad-b2c msdn forum is not allowing me to update the post

    Saturday, April 20, 2019 11:38 PM
  • Hi ,

    Apologies for delay in response.

    Could you please send an email to AzCommunity[at]Microsoft[dot]com referencing this thread, we would like to work closer with you on this matter

    Friday, May 3, 2019 9:36 AM
  • Hi, just wondering if you have found a solution? I'm having the same problem using the same library. It's working with standard email/password auth. But when using 3rd party provider, I'm getting the same error: 

    "error": "invalid_grant",
    "error_description": "AADB2C90090: The provided JWE is not a valid 5 segment token.

    Monday, August 5, 2019 7:23 AM
  • @waterydan please try latest version 1.1.2. the issue is fixed in it
    Friday, April 10, 2020 5:34 AM
  • @HeitorTomaz please try latest version 1.1.2. the issue is fixed in it
    Friday, April 10, 2020 5:34 AM