none
Team Foundation Server online and Safari

    Question

  • Hello,

    I'm experiencing a few issues in Safari connecting to Team Foundation Server 2015 online. It is an on premise installation of TFS with web access and every time I try to access the "Work" page and my queries, or even get to the Work page by opening a recent project, it is either failing, in which case it does not open the page by showing the loading bar, or it shows part of the page and then it stops loading. I need to press Refresh on Safari to make it work.

    Another issue I have is I'm not able to attach files to a WorkItem. After I select the file, it keeps loading the attachment but nothing happens.

    I checked Silverlight plugin, version 5.1.50901 and it is On for that website.

    Any idea?

    Thanks.

    Friday, March 17, 2017 7:00 PM

All replies

  • Hi D Camanni,

    Since you use the TFS2015, just provide some troubleshooting steps:

    (1) Test it using other Environment, for example, use the chrome in this Environment or IE in other system, and then connect the Server, check it again. So we could know that whether it is related to the TFS itself.

    (2) Please make sure that it meets the TFS version requirements:

    https://www.visualstudio.com/en-us/docs/setup-admin/requirements

    (3) Open Safari > click on Safari menu > Preferences > Security > Internet plug-in's: Plug-in Settings > Allow Microsoft Silverlight plug in.

    Reference:

    https://discussions.apple.com/thread/3357697?tstart=0

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 20, 2017 8:39 AM
    Moderator
  • I did steps above.

    Works in IE, I have a VM with Windows.

    I have Safari 10.1

    Attached are settings on the plugin.

    Please advise. Thanks.

    Friday, March 31, 2017 9:00 PM
  • Hi D Camanni,

    >>Works in IE, I have a VM with Windows.

    >>I have Safari 10.1

    If so, at least, we could know that it is not the TFS issue.

    How about using the Safari 10.0.3?

    Thanks,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 03, 2017 8:53 AM
    Moderator
  • >> How about using the Safari 10.0.3?

    Unfortunately I have no way to test with older Safari versions. But thanks

    Monday, April 03, 2017 10:13 PM
  • Hi D Camanni,

    Do you have other TFS Environment like the TFS2017 or Team Services? Actually I couldn't find the issue which was related to the Silverlight, we need to make sure that whether it is related to the compatibility between the higher Safari and TFS.

    Whether the Safari has the debugger tool like the IE which could view the request or response from the server, so it could provide much more information.

    In addition, since it is related to the specific browser, to really help you repro this issue, another suggestion is that you could post this issue to the Safari supported site here:

    https://discussions.apple.com/community/mac_os/safari

    I think the Safari experts could help you repro this issue easily. Of course, if you get any latest information from the Safari supported site, please feel free to share it here, I will keep opening this case for you.

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 04, 2017 6:48 AM
    Moderator
  • Sounds good. Thanks
    Thursday, April 13, 2017 2:39 PM
  • You are welcome, D Camanni.

    If you get any information, please feel free to share it here.

    Sincerely,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, April 19, 2017 2:20 AM
    Moderator