Can't Install Silverlight - Please Help!!!!


  •  Had VS2005, and Latest Express, and the Tools - like Blend, Blend 2.

    Worked for a while on Version 1.0

    Tried to switch to Silverlight 1.1 Alpha, - this is when problems started.

    Suspect Stale Registry keys.

    Even when I removed VS2005, Express, the Tools, still, nothing works.

    Can't even go to version 1.0.

    Pretty frustrating


    Reinstall of latest Express with 3.5  worked, but again the Silverlight Runtime that is part of installation failed.

    Is there anything else I can do- other then make a fresh start with the machine?


    Please Help 

    Tuesday, January 08, 2008 3:19 AM

All replies

  • So installing Silvelright 1.1 failed?  I am trying to understand from your message what the real issue is.  Any chance you don't qualify for 1.1 because of other requirements?  Can you tell us your machine configuration?

    Saturday, January 12, 2008 8:15 AM
  • You need to uninstall 1.1 before installing 1.0.

    Sunday, January 13, 2008 3:28 PM
  • Yes and no...You don't need both installed...your 1.0 apps will work with the 1.1 runtime. If you want to go to 1.0 only, then you do need to uninstall 1.1...but if you just need the runtime for 1.0, you can leave'll work the same (its the same bits inside).

    Sunday, January 13, 2008 3:58 PM
  • Yes, but if your 1.1 install is broken (say because you installed it on top of a 1.0 install) then you need to uninstall 1.1, after that you can install 1.0 or 1.1 as you please. It sounds like he has no need of 1.1, so it makes sense to use the version that isn't an Alpha.

    Sunday, January 13, 2008 10:26 PM
  • Hey guys,I am not much of a forum guy but I am pulling my hair out here. When Orcas was BETA, I had Silverlight 1.0, 1.1, Expression Studio, .Net 3.5 and Orcas all on my Vista Ultimate. No problems at all. I installed the latest Orcas (Professional) release on my machine and now if I try to create a Silverlight project the template fails and says, ” this version of Silverlight is not compatible with the installation of VS 2008.” Any ideas? A similar issue also occurs with Blend. I have tried installing and re-installing. No luck. Silverlight 1.0 still works fine if I create projects in VS 2005.


    Wednesday, January 16, 2008 2:34 PM
  • I had the same problem for the last few days on my Vista 32 with IE7. Each time I tried installing the runtime it "completed" but just asked me to install again. Another thread mentioned checking the permissions on the HKCR\AgControl.AgControl keys and I discovered I had no access. On checking the HKEY_CLASSES_ROOT node's permissions it showed the following message "No permissions have been assigned for this object.".

     I solved my Silverlight issue by uninstalling both Silverlight 1.1 and 1.0 using the Control Panel. Then using Regedit I reset the permissions on the HKEY_CLASSES_ROOT node using the values from another Vista box as an example.

    I believe they should be:

    SYSTEM: Full Control
    Administrators: Full Control
    Users: Read
    CREATOR OWNER: Special

     The CREATOR OWNER permissions are set using the Advanced -> Edit... dialog to be Full Control but with "Apply to" set to "Subkeys only".

     After making that change, I opened a new instance of IE7 and visited and clicked the panel to install Silverlight 1.0 and everything installed normally and was correctly detected.

     Hope this might help,



    Wednesday, January 16, 2008 5:35 PM
  • Thanks for the reply. That's what I have, a 32.

    hmmmmm. I am a little nervous about messing around with registry keys. I will read up a little on it. My goal is to start playing around with Alpha again. Did you get 1.1 working?

    On a separate note, I read somewhere that 1.1 is actually 2.0 now; it’s released, and safe for production. Does anyone know this to be authentic?

    Wednesday, January 16, 2008 7:29 PM
  • The latest release of 1.1 is still 1.1 and is an Alpha. The next release of what was 1.1 will be called 2.0, and will be a Beta.

    Wednesday, January 16, 2008 9:42 PM
  • Hi there guys.

     Well i tried this option to change the access to the registry key and it worked ! First off i thought i had trashed my laptop but after booting up in Safe Mode once, then booting up normally i uninstalled Silverlight and re-installed Silverlight 1.1 Alpha and it works fine in IE 7 Wink But it seems that when changing the settings for the reg keys it seems to have overwritten my previouse settings and my user account didn't work at all. But as i said after booting up in Safe Mode the OS gets gets the latest usable registry and all is fine.

    Thursday, January 17, 2008 6:07 AM
  • Thanks Daniel - Although it does still say on the Get Started Page that even Alpha should not be used in production. The code managed model has many benefits over the JS version so I am really trying to get to grips with that. I believe what you say so please don't take offense but are you sure Alpha its ready for production?

    Sigurjonl's experience only strengthens my concern regarding the Registry Keys. Before I attempt it, can someone look at my server requirements and see if there is something that jumps out?

    Windows Vista Ultimate

    Precision WorkStation 390

    Intel(R) Core 2 CPU 6600 @ 2.40GHz3.50 GB RamATI FireGL V7200Expression Studio - Full Version – and Blend Sept PreviewSQL Server 2005 Standard - Full VersionVisual Studio 2005 Standard - Full VersionVisual Studio 2008 (aka Orcas) Professional - Trial VersionSilverlight (aka WPF/E) 1.0 - 1.1 (removed)

    .Net Framework 1.0, 1.1, 2.0, 3.0, 3.5

    Thursday, January 17, 2008 10:27 AM
  • removed duplicate

    Thursday, January 17, 2008 10:28 AM
  • No, the Alpha is not ready for production environments. The EULA even says:
    "This license grants you permission to test the software in “beta” operating environments. You may not test or otherwise use the software in a live operating environment or a production website unless Microsoft permits you to do so under another agreement. "

    Once Microsoft thinks 2.0 is ready for production it will be released with a go live license. Silverlight 1.0 wasn't go live until a Beta release.

    Thursday, January 17, 2008 2:23 PM
  • Easy there buddy. What part of don’t take offense do you not understand? I look back two threads and realized you never really answered that anyway. I was working off the two part question I asked. Sorry. I am simply trying to get answers.


    Thursday, January 17, 2008 2:42 PM
  • I didn't take any offense. I'm sorry if my answer was harshly worded.

    Thursday, January 17, 2008 2:49 PM
  • No problem.

    Thursday, January 17, 2008 3:05 PM
  • I am having a similar problem..

    I am asked to update silverlight everything I turn on my computer

    I supposedly have 1.0 on my computer and I can't install 2 and I can't unistall 1

    I am not familiar with edditing registerys but I really wanna fix this.




    Thursday, August 07, 2008 3:13 PM
  • It’s been a few months since I had a Silverlight install issue.

    To uninstall Silverlight 1.0 you will need to remove it using Add/Remove programs. You will need to do this before installing the latest Silverlight as you know. There is a special case with the install of Silverlight 2.2 in that you will you need to manually remove an install fix from the previous version of Silverlight. There should still be a KB article on the latest Silverlight install splash page that walks you through it.

    Highest Regards --

    Thursday, August 07, 2008 8:34 PM

    I wish this were the case..

    It will not unistall.

    I tried using Add/Remove and it won't get rid of it.

    Friday, August 08, 2008 6:02 PM
  • As far as I know, if Silverlight 1.0 and/or 1.1 is still stuck on your system after an Add/Remove, the only way to remove it is by manually removing the registry keys from your system as stated in previous threads. Although, there is a method that sounds a little crazy but has proven effective. Using software like Ad-aware to clean registry keys from your system without you manually tampering with them. Their website is Even the latest Norton Anti Virus can do the same job.

    You install their software and run a spyware scan like you would normally. The abandon Silverlight registry keys should get picked up in the scan. You can either quarantine or remove the keys completely. Do a restart of your system for @%!&s and giggles. Then attempt the install of Silverlight 2.0 or 2.2. Remember, there is still that manually step of removing the patch for Silverlight 2.0 or lower that needs to be done before 2.2 can be installed.


    Friday, August 08, 2008 6:37 PM
  • I had the same problem and it turned out my installer was set to disabled and I had to set to manual.

    I found the instructions on the Microsoft support site. Everything has installed without anymore problems.

    This one worked for me.

    Method 2: Make sure that the Windows Installer service is not set to Disabled

    1. Click Start
      Type services.msc in the Search box or click Run then type services.msc in the dialog (Windows XP or Windows Server 2003), and then press Enter to open Services.
    2. Right-click the Windows Installer service, and then click Properties.
    3. If the Startup type box is set to Disabled, change it to Manual.
    4. Click OK to close the Properties window.
    5. Right-click the Windows Installer service, and then click Start. The service should start without errors.
    6. Try to install or to uninstall again.

    Hope it helps.

    Friday, October 21, 2011 12:51 PM