Can't Get Live Streaming from CTV Olympics - Problem with Silverlight


  • I have been watching CTV Olympics LIVE for a week. Today it won't work. I have reinstalled Silverlight, and still not working. Every other web site does. I have a desktop and laptop. They are both on the same network. The laptop gets the live feed, the desktop does not.
    Strange thing is that on the frame where the video plays, I have the ZOOM button showing at the bottom of the frame. On the laptop where I am getting a connection, the ZOOM button is half the size and below it is a LIVE button and it is in RED Colour. Despite all of my efforts, I cannot get the LIVE button to appear on my desktop. As I said, both computers worked great for this site yesterday. Can someone help me find that LIVE button!!!!

    Just to make it more clear, I have taken some screen prints. Take a look just below where the video would be playing. On the desktop, you will see a large button ZOOM. The desktop will not play the streaming videos, whether they are live or pre-recorded.
    On this next screen shot, you can see that the ZOOM button is half the size, and the bottom half has LIVE. This is from my lap top where I am watching live.
    I believe that this may be the problem that many people are having. Can someone advise how I can get that LIVE button to reappear??


    Wednesday, August 08, 2012 8:42 PM


All replies

  • Yeah, same here. Hoever, I can't even get it to working on Firefox. It will just show the image you have on your first picture. I can't manage to watch any videos. Therefore, I have to use Chrome in order to view it.

    Thursday, August 09, 2012 11:26 AM
  • Thanks Lannny.  I have tried Firefox and no luck.  I just tried Google Chrome as well and the same thing.  On desktop there is no LIVE button showing and no video, whether live or prerecorded.  On the laptop, LIVE button shows on all three browsers and I can watch the events live and prerecorded.  This is driving me crazy as it makes no sense!!  I still think it has something to do with Silverlight, and not the browser.  On another website where I posted this same complaint, many people have mentioned that they have the exact same problem, but no one knows how to fix it.

    Thanks again,



    Thursday, August 09, 2012 12:04 PM
  • Chrome works for me somehow. I just don't like it because it has a lot of ads before watching any video. On Firefox, I have Adblock so it doesn't show it.

    I was able to watch the Olympics just fine from Day 1. Problems started occuring yesterday.

    Thursday, August 09, 2012 1:15 PM
  • Hi BradF,

    Please tell me the result if you can play this video or not. If cannot, you can refer this blog on "how to manually clean up a broken Silverlight installation": 

    And what version of Silverlight you have installed?  Silverlight 4 does not support 64-bit browser.

    Best Regards,

    Thursday, August 09, 2012 11:32 PM
  • Hello Haixia,

    I was able to play the video with absolutely no problems.  I am using Silverlight version 5.1.10411.0.  I looked through somed long lists of discussions on that blog, but could never find anything that helped.  I tried a few things.  Perhaps if I was able to get a different version of Silverlight - like an earlier version.


    As I stated before, I am hearing that a lot of people are having this problem, and for all of them it started on August 8th.  Was there an update of Silverlight on that day?


    Many thanks



    Friday, August 10, 2012 9:50 AM
  • I was able to play the video with absolutely no problems. 

    According to my experience, your Silverlight has been installed correctly, so I will suggest you contact the relevant support from the web site( ctvolymlics), Contact Us at the bottom of the site.

    Best Regards,



    Sunday, August 12, 2012 10:00 PM