none
Silverlight not recognised by my computer

    Question

  • I recently bought a new laptop. I have installed and un installed silverlight several times.  I need it to access my work roster from home and it all worked perfectly on the old laptop. However all that happens on this new one is being directed to download silverlight every single time I try to access my roster and if I do so, when I click on install, it says I already have the current version. I've shut the browser, restarted the computer several times but it still doesn't work.
    Friday, March 24, 2017 4:26 AM

All replies


  • Hi Rebanne59,

    As far as I know, Silverlight is supported in IE 11.

    According to your description, I suggest you can clean a corrupted Silverlight installation and then reinstall Silverlight

    How to clean a corrupted Silverlight installation and then reinstall Silverlight:
    https://support.microsoft.com/en-us/kb/2608523

    Download the latest Silverlight plugin and install Silverlight.

    Then, You can visit the following link. It will show  Silverlight installed state.

    Get Microsoft Silverlight:
    https://www.microsoft.com/getsilverlight/Get-Started/Install/Default.aspx

    You can also use registry:
    Open Registry Editor by typing ‘regedit’ in Run command and navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Silverlight, and view the version entry on the right pane.

    Best Regards,

    Yohann Lu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Rebanne59 Tuesday, March 28, 2017 6:45 AM
    • Unmarked as answer by Rebanne59 Tuesday, March 28, 2017 6:45 AM
    Tuesday, March 28, 2017 5:34 AM
  • I did as you suggested and it still doesn't work. I am running the latest Mozilla Firefox. Thank you for trying
    Tuesday, March 28, 2017 6:46 AM
  • Hi Rebanne59,

    Do you use the IE11 64 bit? If you use the 32 bit, how about the result?

    Please also really enable it under your IE:

    You could enable the Silverlight add-on in IE using the following steps:

    1. Click Tool menu and select Manage add-ons in IE.
    2. It will show "All add-ons".
    3. Under "Microsoft Corporation" category, please select "Microsoft Silverlight"
    4. Click "Enable".

    Check it again.

    Of course, since you use the Firefox now, and you could mark it as the temporary answer before you will use the IE again in the future.

    Thank you for your support.

    Sincerely,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, April 04, 2017 7:06 AM
    Moderator