Cannot install Silverlight, unknown reason?


  • I've searched everywhere on my computer. It is not under add and remove programs, it's not in the registry, and it's not in my program files. I know I installed it once in the past, and I wanted to upgrade it. Why can't I install it? How do I find out what's wrong?
    Sunday, April 11, 2010 2:24 PM

All replies

  • Silverlight should be listed under installed updates when look in add remove programs

    Sunday, April 11, 2010 2:38 PM
  • It's not. I have no idea why, and I still can't install it. It takes me to the website with this message: Message ID: 1603 A fatal error occurred during installation. Please take the following steps None of said steps have worked.
    Sunday, April 11, 2010 2:40 PM
  • Hummm... that strange...

    As Ken mentionned if it's already installed then it should indeed be listed under installed updates
    when look in add remove programs through your Control Panel.

    Also if you run the regedit it should also appear
       '- Microsoft
          '- Microsoft SDK's
             '- Silvelright
                '- v 3.0

    Have you checked the following link dealing with
    You receive an "error 1603: A fatal error occurred during installation" error message when you try to install a Windows Installer package

    or check the following thread

    Maybe this can help you solve your problem.


    Sunday, April 11, 2010 7:45 PM
  • When I try to install it, it does bring back its entry under add/remove programs. I keep getting alerts that the file is corrupted. I tried both links you sent, but neither fixed the problem. CCleaner hasn't helped either sadly.
    Sunday, April 11, 2010 9:33 PM
  • I've been trying to install Silverlight and have been getting "...SilverLight.exe is not a valid Win32 application.".  Every time I download the SilverLight.exe the file size is different.  I think maybe there is a problem with the download site?

    Wednesday, April 14, 2010 1:30 PM
  • Where are you downloading it from? is the best place to get it.

    Wednesday, April 14, 2010 4:00 PM
  • Same problem...different file size and when launched get the "...Silverlight.exe is not a valid Win32 application."

    Wednesday, April 14, 2010 4:12 PM
  • If possible can you enumerate the steps you're taking/what you see once you go to and also the browser version, and OS?

    Wednesday, April 14, 2010 5:55 PM
  • Try checking the silverlight log file under the (for Vista) C:\users\accountname\appdata\local\temp\ directory. I had that same error, it turned out to be an access denied error on the HKLM\Software\Mozilla\Firefox\Extensions key. I have McAfee Enterprise 8.70i installed on a locked down Vista machine and I went round in circles trying to install Silverlight_tools version 4.

    Turns out I had to go to Start->All Progams->McAfee, right-click on VirusScan Console, then run as administrator.

    I disable Access Protection which involves watching it as it re-enables itself every 5 minutes or so. As long as I keep it disabled during the install of the various Silverlight plugins and tools, the install succeeds and Visiting this site with Internet Explorer 7 shows Silverlight 4 is installed.

    I guess that even though my PC does not have FireFox installed on it, McAfee doesn't care, as its protection scheme is apparently "block all firefox extensions at all costs". Silverlight also for some unknown reason to me, is hard set to change a value under that Mozilla Firefox Extensions key, and it aborts if it cannot do so.

    The one thing I got from this experience is I'm quite impressed at how much power McAfee has over my PC. I went into regedit, took ownership, gave my account full control, and cascaded the permissions throughout the Mozilla key and its subkeys, yet I could NOT change a value under the Extensions key. It always gave me an Access Denied message. Once I disabled McAfee Access Protection, I hit delete on the Mozilla key and away it went.

    I hope this is helpful to someone. It blew my mind that Vista seemed to ignore my deletion requests even though I had full control AND ownership of the registry keys.

    I'm sure this approach applies to other AV softwares like Norton Internet Security, etc. Try disabling your AV during install or manually manipulating the keys mentioned in the silverlight log file.

    Friday, June 04, 2010 2:55 PM