Try to play Netflix with Chrome, nothing loads and get "Could not load Silverlight plug-in" message


  • As the title says, whenever I try to watch something on Netflix using Chrome on windows 7 64bit, I get a message that tells me "Could not load Silverlight plug-in." The thing is, Netflix works fine when I use Firefox; it's only Chrome that is having trouble. 

    I have tried so many things, such as disabling and reenabling the plug-in, uninstalling and reinstalling Silverlight, restarting browser and computer, clearing my cookies, running CCleaner, and allowing the netflix site through as a trusted site on IE. Nothing has worked so far. 

    Monday, July 29, 2013 10:34 PM


All replies

  • Hi,

    It is introduced in our official websites that Silverlight supports Chrome 12+ in Win7, please check your system and some other configurations according to this and do some modification if necessary.

    Please provide more detail if the solution above dose not work and we will follow up in time according to your feedback.

    Yunjie Pei
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, July 31, 2013 3:29 AM
  • Hi Yunjie,

    Your suggestion did not fix my issue. It simply stated that "I am ready to use silverlight," I guess because everything is current and up to date on every browser I have and I am unable to watching Amazon or Netflix on any browser that I have. =( Everything worked fine until I installed the most recent windows update for Silverlight. When I rebooted my computer, nothing worked. I have also tried everything that elsonj has tried and have had the same results. Please advise what else I should try. What more do you need to know, except that this seems to be an issue that a lot of people are having on and off with Silverlight...

    Tuesday, August 20, 2013 2:59 AM
  • There is a fix and the fix is not to use Silverlight, at least with Netflix. Under "Your Account" settings in Netflix choose the "Playback settings option". Check the box to "Prefer HTML5 player instead of Silverlight" and save. I would also suggest that you completely close and reopen Chrome. Hope this helps. 
    Monday, December 09, 2013 2:00 AM
  • I have had this problem recently and I have found its not Chrome and not directly Silverlight.

    I followed the listed instructions posted by Yunjie Pei and found I still had a problem. I started tracking down other software that used the Silverlight protocol and found that Skype was not terminated when I exited the program. I opened the task manager and forcibly terminated the process. I then exited Chrome and restarted the browser and netflix loaded.

    Seems that Silverlight is having a problem releasing programs using its processes and that terminating the orphans allows a new process to be hooked.

    Also, Moonshine is pretty awesome. 

    Monday, December 09, 2013 7:22 AM
  • has anyone tried fixing microsoft Net framework to fix the problem

    Wednesday, January 22, 2014 1:31 AM
  • Doesn't work. These are already my settings, and it still won't load. 

    I watch Netflix via Chromecast so there's just no way to use any other browser to watch Netflix on my TV. 

    Saturday, February 01, 2014 4:06 AM
  • I also had this problem with everything that played video on chrome, from netflix to youtube, and I fixed the problem by uninstalling a program called Webroot. I'm not exactly sure why it was there in the first place or what it does but it did fix the problem!
    • Proposed as answer by fadedlightning Monday, February 10, 2014 4:02 AM
    • Unproposed as answer by fadedlightning Monday, February 10, 2014 4:04 AM
    Monday, February 10, 2014 4:01 AM
  • Elsonj,

    This may be far overdue, however the fix that worked for me was to go to chrome settings>privacy>content settings>plug-ins. This will open your plugins that are installed on Chrome.

    One of plugins is Silverlight and next to it is a check box that says "Always allowed." I checked it, and voila! Netflix running without a problem.

    Not sure of the long term ramifications for the rest of my browsing experience yet, but still, a good short term fix until a new update fixes whatever the issue is.

    All best,

    • Edited by Reese Burgan Wednesday, April 02, 2014 3:52 AM grammar
    • Proposed as answer by JinHoshi Friday, May 02, 2014 11:01 PM
    Wednesday, April 02, 2014 3:51 AM
  • You're awesome!~ :D Thnxx yous ^.^
    Saturday, April 26, 2014 9:57 PM
  • You, I like you...

    I just started getting this problem when I got home from work today, tried your fix and immediately my Silverlight and Netflix are acting friendly again!

    Friday, May 02, 2014 11:00 PM
  • I've tried each of the solutions listed here and so far nothing helped.  I just don't understand.

    Tuesday, July 15, 2014 11:40 PM
  • Thanks Reese, you're a lifesaver! Just in case anyone arrives on this page and is using a Mac (like me) be aware that from the Plug-ins section of Content Settings you need to then click the 'Disable individual plug-ins' link. This will take you to the place where you can 'always allow' Silverlight.

    The even easier version is just navigate straight to chrome://plugins/ in the address bar.

    Wednesday, July 23, 2014 7:46 PM
  • I am using Windows Vista and had the same problem each time I tried to view Netflix, i.e.  I was told that I needed to install 'Silverlight'.

     I downloaded and installed it and tried again to view Netflix.  Got the same message again.  After going round in circles trying several suggestions on other forums and getting nowhere, I came across the suggestion above to check the Plug-ins section.

     I found that 'Silverlight' had installed, but was not enabled!  I enabled it and Netflix now works a treat.  So, thanks Reese, your help is greatly appreciated.  (I found it easier to copy and paste from above chrome://plugins/ into the address bar)

    Saturday, July 26, 2014 12:08 AM
  • Nothing works for me.. Any ideas?
    Tuesday, July 29, 2014 7:53 PM
  • Nothing works for me either... 

    I have tried all these suggestions here and the only thing that worked was uninstalling/re-installing silverlight... But after watching one movie I got the error message again. So do you mean to tell me that I have to do this for each show I want to watch?

    Get it together Microsoft, Bill Gates should not be happy with this!!!! 

    • Edited by RawBeatnik Sunday, August 17, 2014 8:35 PM
    Sunday, August 17, 2014 8:34 PM
  • Actually, the reverse is true, particularly when you are running an underpowered asus netbook (moi). I also had playback problems, consulted with Netflix support (to no avail, although the clue was in the HD button not appearing in chrome.)

    Anyway, the solution was to uncheck "Prefer HTML5..."

    (If anyone from netflix support sees this, please incorporate into your procedures and fixes.)



    'There is a fix and the fix is not to use Silverlight, at least with Netflix. Under "Your Account" settings in Netflix choose the "Playback settings option". Check the box to "Prefer HTML5 player instead of Silverlight" and save. I would also suggest that you completely close and reopen Chrome. Hope this helps. '

    • Edited by pjmoym Tuesday, October 07, 2014 3:16 PM insert post I was replying to
    Monday, October 06, 2014 10:54 PM