none
OOB Install on MacOSX 10.9 Maverick fails

    Question

  • MacOSX 10.9, Silverlight 5.1.20913.0

    Application.Current.Install();

    Opens a warning window displaying installation information.

    Do you want to install...   ...Publisher:...   ...This application can access.. Cancel ... Install

    After clicking Install button the windows closes and visually nothing more happens.

    Behind the scenes, in the users Library:Application Support:Microsoft:Silverlight:OutOfBrowser there is a new folder  containing the .xap and some other files.

    There was no download progress indicator, there ist no OOB application in the download folder.

    Friday, November 1, 2013 4:16 PM

Answers

  • Yes, this application installed without problems on previous OS versions on Macs.

    Workaround is as follows:

    Safari/Settings/Security/Internet-Plugins:Allow Plugins -> Organize Website Settings... select Silverlight on left side, on right side select hostname, pulldown 'Execute in unsecure mode'

    Best Regards

    • Marked as answer by Enter_Rene Monday, November 4, 2013 4:44 PM
    Monday, November 4, 2013 4:43 PM

All replies

  • The same issue is happening to us as well. We noticed that this problem is only in Safari, while the same exact install dialog works if it was launched from Chrome.
    Friday, November 1, 2013 11:17 PM
  • Hello,

    Thanks for reporting this issue.

    I want to confirm with you if this oob application can install on Mac's other version OS? if this is a specific issue to Maverick OS, I recommend you repost this issue to our Connect feedback portal at http://connect.microsoft.com with concise steps for reproducing the problem and what the expected behavior should be.

    Our developer will evaluate them seriously and take them into consideration.

    Best regards,  


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Enter_Rene Monday, November 4, 2013 4:44 PM
    • Unmarked as answer by Enter_Rene Monday, November 4, 2013 4:44 PM
    Monday, November 4, 2013 12:13 PM
  • Yes, this application installed without problems on previous OS versions on Macs.

    Workaround is as follows:

    Safari/Settings/Security/Internet-Plugins:Allow Plugins -> Organize Website Settings... select Silverlight on left side, on right side select hostname, pulldown 'Execute in unsecure mode'

    Best Regards

    • Marked as answer by Enter_Rene Monday, November 4, 2013 4:44 PM
    Monday, November 4, 2013 4:43 PM