none
Could not load file or assembly 'Microsoft.DataWarehouse.SQM, Version=10.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The module was expected to contain an assembly manifest. (SqlMgmt) RRS feed

  • Question

  • I am all of a sudden getting the above error when I tried to backup any database on my server. I am running windows server 2008 R 2 with Microsoft Sql server 2008 R 2 developer edition. I have Microsoft.SqlServer.Sqm version 10.50.1600.1 in all the necessary places with a size of 61.8 KB. Can anybody help me.?

    Ebenezer

    Friday, November 22, 2019 4:22 AM

All replies

  • Hi denkyira,

    SQL server 2008 R2 is out of Extended support at 7/9/2019. Please refer to End of support for SQL Server 2008 and SQL Server 2008 R2. I suggest you upgrade your SQL server to a newer version.

    For your issue, please check if below link could help you. http://www.sqldbadiaries.com/2010/10/20/how-i-fixed-could-not-load-file-or-assembly-microsoft-sqlserver-smo-version10-0-0-0-issue/

    Best regards,
    Cathy 

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, November 25, 2019 8:34 AM
  • Hi 

    Thanks a lot for your response. I have reviewed the Microsoft.sqlserver.smo in my C:\Windows\assembly and compared it with the one in C:\Program Files\Microsoft SQL Server\110\SDK\Assemblies and could tell there is a difference.

    10.50.4042.0---->C:\Windows\assembly

    10.50.1447.4----->C:\Program Files\Microsoft SQL Server\110\SDK\Assemblies

    I am going to follow the link you gave to fix my issue since I have a good working image.

    I will update when l am done tonight

    Thanks. 



    Ebenezer

    Monday, November 25, 2019 7:21 PM