none
First record visible although grouping is active? RRS feed

  • Question

  • Hi,

    I have a question concerning my actual report.

    1.) Under "Row Groups" I built the following structure.

    level (grouped by level column)

        status (grouped by status column)

            details (not grouped)

    For "level" and status the visibility is set to "show", for "details" it is set to "hide". You can change the visibility for details through status and for status you can change it through level. If I open my report I can see that all columns are filled, although I am on "grouping level". I don't want to see details at this point.

    Here is what I get:

    wrong

    And this is what I want:

    right

    And here is my report in VS:

    report


    Can you help me with that?

    Best regards
    pgosch

    Monday, September 16, 2019 2:00 PM

All replies

  • Hi pgosch,

    There are several steps you could follow to hide the first record in this kind of situation.

    First of all have your togglement and visibility property all set as you'd already done. Then:

    1.Insert a row - Outside group -Above to the detail rows. See:

    2. Set row visibility for this added row, toggle it on its parent item. In my test--subcategory, in your case it should be status.

    After this, you should have the table working as needed.

    Hope this helps.

    Regards,

    Lukas


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, September 17, 2019 2:58 AM
  • Hi Lukas,

    thanks a lot for your answer, it is better now, but not perfect. Now it looks like this.

    But if I toggle by "level", it looks like this. In this case the other columns besides level and status should be empty as well. Do you have any idea what to do?

    Best regards
    pgosch

    Tuesday, September 17, 2019 5:40 AM
  • Hi Lukas,

    thanks a lot for your answer, it is better now, but not perfect. Now it looks like this.

    But if I toggle by "level", it looks like this. In this case the other columns besides level and status should be empty as well. Do you have any idea what to do?

    Best regards
    pgosch

    So how exactly should result come for you when you toggle on level?

    do you mean you want to show status value also along other detail values (status, responsible etc)?


    Please Mark This As Answer if it solved your issue
    Please Vote This As Helpful if it helps to solve your issue
    Visakh
    ----------------------------
    My Wiki User Page
    My MSDN Page
    My Personal Blog
    My Facebook Page

    Tuesday, September 17, 2019 6:29 AM
  • Hi Visakh,

    it should look like this, if I collapse by "level":

    Status should not be visible and all other columns should be empty.

    My report looks like this at the moment:

    Best regards
    pgosch

    Tuesday, September 17, 2019 6:33 AM
  • Hi pgosh,

    What have you set for toggle on "level"? 

    We only need to set the added blank row visible and toggle on "status" . And status toggle on level. No other setting is needed.

    See my test behavior.

    Regards,

    Lukas


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, September 17, 2019 7:03 AM
  • Hi Lukas,

    I checked my design, but I could not see any differences. Here are some screenshots:

    Details:

    Status:

    Level:

    Blank Row:

    blank row

    Design:


    • Edited by pgosch Tuesday, September 17, 2019 7:25 AM text changed
    Tuesday, September 17, 2019 7:22 AM
  • Hmmm,seems the settings are all the same?

    What version of SSDT/Report Builder and SSRS  are you using now?


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Tuesday, September 17, 2019 8:23 AM
  • VisualStudio Professional 2019 - Version 16.1.3 and SQL Server 2017 Version 14.0.600.744 (Oktober 2017)
    Tuesday, September 17, 2019 8:39 AM
  • I don't have VS Professional 2019, couldn't do more test on it.

    Could you please give report builder a try, maybe it's a development tool issue.

    As I tested in SSDT 2017 and Report builder, they both perform well. 


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, September 17, 2019 9:53 AM
  • Hi Lukas,

    I also checked the issue with the report builder, but there was no difference at all. Afterwards I deleted my entire table and started from point zero. Now everything works fine, although I did not change anything as far as I remember.

    Nevertheless thank you very much for your effort. By the way, are you German?

    Best regards
    pgosch

    Tuesday, September 17, 2019 12:34 PM
  • Hi Pgosch,

    I have one thought, that this behavior maybe related to the blank row added before the visibility order or afterward. Or other settings somewhere hidden in the report.

    But anyway, glad the thing has finally worked out. You could mark the first post as answer, this may help people with similar issue to see it.

    No, I am not German, just studied few years in Germany and liked this German name. :)

    VG,

    Lukas



    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, September 18, 2019 1:23 AM