locked
SL 2 beta 2 installation - fatal error RRS feed

  • Question

  •  I have:

    Exe (c:\1ae937c35ae3002089f705\silverlight_uninstallrtmpatches.exe) failed with 0x80070643 - Fatal error during installation. :
    [6/7/2008, 9:14:44] (IronSpigot::ExeInstallerBase::PerformAction) PerformOperation on exe returned exit code 1603 (translates to HRESULT = 0x80070643)
    [6/7/2008, 9:14:44] Action complete
    [6/7/2008, 9:14:44] (IronSpigot::LogUtils::LogFinalResult) Final Result: Installation failed with error code: (0x80070643), Fatal error during installation. 

     running silverlight_chainer.exe on my XP (SP3) machine. Have VS2008 prof, Blend 2.5 june preview. Anyone has an idea how to fix or skip this step?

     

    Konstantin
     

    Saturday, June 7, 2008 9:21 AM

Answers

  •  Sorry, this was my mistake. I had to enable "Show Updates" to see it. I was confused because I can see this patch In VS about dialog box but not in Add/Remove programs. Have to learn how to use it.

     

    Thanks a lot for your help. 

    Saturday, June 7, 2008 1:27 PM

All replies

  • Please check to see if you have KB949325 installed.  If so, uninstall it.

    For XP:

    1. Open the Add/Remove Programs dialog from the Control Panel
    2. Click 'Show updates' at the top of the window
    3. Remove KB949325 (it will be listed under your version of VS)

    Brad.

    Saturday, June 7, 2008 9:27 AM
  •  I don't have this patch.

    Saturday, June 7, 2008 1:13 PM
  • Interesting.

    Do you have VS08 SP1 Beta installed or any other patches?

    Also check the version of Microsoft.VisualStudio.Web.Application.dll

    C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\Microsoft.VisualStudio.Web.Application.dll

    VS 08 RTM 9.0.21022.8
    Silverlight Tools Beta 1 (for VS08 RTM) 9.0.21116.48
    Silverlight Tools Beta 2 (for VS08 RTM) 9.0.21022.108
    VS 08 SP1 Beta 9.0.30428.1
    Silverlight Tools Beta 2 (for VS08 SP1 Beta) 9.0.30428.9

    As a last resort you could try unpacking the silverlight_chainer.exe and installing the component individually.  Let me know what version you have before we resort to that step.

    Brad

    Saturday, June 7, 2008 1:19 PM
  •  Sorry, this was my mistake. I had to enable "Show Updates" to see it. I was confused because I can see this patch In VS about dialog box but not in Add/Remove programs. Have to learn how to use it.

     

    Thanks a lot for your help. 

    Saturday, June 7, 2008 1:27 PM