Silverlight crashes in all browsers


  • Silverlight crashes in all browsers that I try:  Firefox 4, Chrome 10, IE 8 (32 and 64 bit).  It doesn't matter what I use, Silverlight just plain doesn't work, period.

    I ran a full antivirus scan and my system came up clean.  I disabled my antivirus and antispyware protection along with my Windows firewall as a temporary test, and it made no difference.  I restarted my computer, and uninstalled and reinstalled Silverlight -- and still it crashes.

    It is extremely important for me to be able to run Silverlight on my home PC because I telecommute and one of the remote control tools that I use to connect to customers' machines runs under Silverlight.

    I saw a thread that says to make sure that Tablet PC Input Service is started and is set to run automatic.  Mine is already set that way (even though I do not have a tablet PC.  It's just a desktop PC running Windows 7 64-bit).

    In need of alternate suggestions...


    P.S. Microsoft, your "Tags" instructions for forum posts say to "sepertate" multiple tags with semicolon.  Nice spell-checking there.  :p

    Monday, July 04, 2011 4:38 PM

All replies

  • what do you mean by "crashes" and "just plain doesn't work"?

    do you get an error message?

    does it load anything at all?  does it freeze the browser?  does the browser just show a white screen?

    does it happen with all silverlight apps/sites or just the one in particular you're trying to use?

    where are you installing silverlight from?  are you doing it manually?

    does it happen on other computers?


    Monday, July 04, 2011 6:12 PM
  • For example, on Microsoft's own Silverlight home page:  

    Chrome counts up a certain percentage when loading  (usually to 100%, but not always), then in the space where the Silverlight content is supposed to be, I get the "Aw, Snap!" sad face icon, and a gold bar notice up on top that says "The following plug-in has crashed:  Silverlight."  Eventually it will come up with a dialog box that asks if I want to Wait or Kill the Page.

    In Firefox, I immediately get, in the space where the Silverlight content is supposed to be:  "The Silverlight plugin has crashed."

    In IE 8, even though Silverlight has been installed, I get the message "Silverlight has not been installed."  If I then try to install it, it tells me that the same version of Silverlight is already installed.

    The problems happen on any Silverlight-content site.

    I installed Silverlight from Microsoft's own site,   I actually uninstalled it and reinstalled it, thinking that maybe I had a corrupted installation.  No luck.

    I have only one computer so don't know if it would happen on others that I would have, but that maybe seems irrelevant anyway since evidently other people's computers do not have the issue.  So there's your answer to the question of whether it is a global problem that is happening on all PCs.  I would surmise that it's not.

    Hope that answers your questions.  Thanks.

    Tuesday, July 05, 2011 1:16 AM
  • It's obviously not a browser problem in my case, since it is happening in all browsers.

    Tuesday, July 05, 2011 8:06 AM
  • Did you have or are you currently running a beta?  I've heard of people having problems with beta's not entirely uninstalling that then cause problems with the actual release.

    Tuesday, July 05, 2011 8:16 AM
  • Nope, I'm not running a beta; it's the current legit release.

    Tuesday, July 05, 2011 8:40 PM
  • Something weird about Silverlight:

    If I run it from the Start menu to bring up its config window, if I click on the Permissions tab it comes up but gives me no way to add sites to allow.  Clicking on any of the buttons does nothing.

    And if I click on the Application Storage tab, Silverlight just closes.  Huh?

    Tuesday, July 05, 2011 8:56 PM
  • Run WHAT from Start menu, the xap?  I've never seen what you are describing.  Sounds interesting.

    Wednesday, July 06, 2011 8:18 AM
  • there's a 'Microsoft Silverlight' entry added to the Program Files list.  Running it brings up the About/Updates/.../Application Storage config screen.

    Wednesday, July 06, 2011 8:29 AM
  • Cool.  I'm not sure I ever noticed that before.  When I click on the application storage tab, it shows a whole bunch.  Sounds like maybe isolate storage is mucked up somehow.  That would explain a lot.

    Try logging onto the machine with a different user.  That should use a different isolated storage place.  If it works, you've "isolated" the problem to isolated storage.  If it is, I'm not sure what to do about it.

    Wednesday, July 06, 2011 8:31 AM
  • PenaltyShot, are you running your pc with limited privs?  I'm not sure I've ever tried to run/install SL without admin rights.  Maybe you have a limited/strange set of rights that is causing SL to barf?

    Wednesday, July 06, 2011 8:36 AM
  • Hi,

    Silverlight crashes in all browsers that I try:  Firefox 4, Chrome 10, IE 8 (32 and 64 bit).  It doesn't matter what I use, Silverlight just plain doesn't work, period.

    Since the issue can not be reproduced at my side ,I would like to suggest you to check the links below for some similar threads which provide some solutions for the same issue.

    Silverlight crashes IE8, generates a plugin crash in Firefox and crashes SkyDrive browser page.

    keeps saying not installed

    It is extremely important for me to be able to run Silverlight on my home PC because I telecommute and one of the remote control tools that I use to connect to customers' machines runs under Silverlight.

    In addition ,I would recommend that you can refer the link below for the Minimal Requirements of installing silverlight. Please check it and see whether it helps.

    Hope it can help you.

    Thursday, July 07, 2011 3:18 AM
  • To answer some of the previous questions:

    I was already running under an Administrator account, but I created a new Administrator account just for the heck of it and signed in under that.  No change whatsoever in Silverlight's behavior under the new account.  Even the program tabs that I mentioned before behave the same.

    Ming, I'll try your suggestions when I have time later.  Thanks.

    Thursday, July 07, 2011 2:17 PM
  • OK, I checked out Ming's links.  Unfortunately, they weren't of much help.

    The first link is a thread that ended with the solution being to uninstall and reinstall Silverlight.  I've done that multiple times now; it hasn't made any difference.

    The second link just shows me that, at least according to that page, the latest (gold, not beta) version of Silverlight is installed properly.  And I have well beyond the minimum requirements to run it.

    Thursday, July 07, 2011 8:43 PM
  • I guess I stumped the experts  :-(


    Monday, July 11, 2011 12:06 AM
  • i bet you could at least get it working on an XP virtual machine.  that way you could at least use the SL app for work.  here are instructions on how to setup an xp virtual machine on win7, if you're interested:

    this one is tricky.  i wouldn't want to suggest wiping your machine and reinstalling windows, but...

    Monday, July 11, 2011 3:17 AM
  • I'm guessing an older version of Silverlight isn't correctly uninstalled for some reason.  Can you check what version it "thinks" is installed, by checking Add/Remove programs?  And let us know what version of Windows you are running.

    Try running the resolution steps in this article - basically, uninstall silverlight, delete the silverlight registry keys, delete the silverlight folder, reboot (this is VERY important), and then reinstall:

    2560901 Troubleshoot problems installing Silverlight;en-US;2560901


    Monday, July 11, 2011 7:22 AM
  • Thanks very much for responding, guys.

    You know, I didn't even think about the fact that I do have an XP VirtualBox machine that I use for my flatbed scanner, since Canon in its infinite wisdom decided not to release any 64-bit drivers for the device.

    Sure enough, Silverlight works in that.  So even though it's a little clunky, that's an acceptable workaround.  Thanks!

    I checked the version of Silverlight that Win7 x64 thinks is installed on my host machine.  It's 4.0.60531.0

    Thanks again.

    Monday, July 11, 2011 9:59 PM
  • On a totally unrelated note:  LOL at all of the Re: Re: Re: Re: Re: Re:'s that get tacked onto the subject titles.  Seems rather pointless.

    Monday, July 11, 2011 10:04 PM
  • So the issue never did get resolved?  I'm having the same problem and would like to know how to fix it.  Only difference between your situation and mine is that I'm running Windows Vista Home Premium, not Windows 7.

    Friday, July 22, 2011 7:15 PM
  • Also having this problem.

    Saturday, July 23, 2011 7:59 PM
  • I have a similar problem and I can say a serious problem, silverlight app is functioning very slow in Chrome, Mozilla and Safari (Windows latest versions) but in IE works fine. After detecting that, I tryied to make changes in Mozilla's about:config with no result (I did not try with the other browsers). What is going on? It is safe to continue deploying silverlight applications for all browsers any more? Did the other browsers start having a politic against Silverlight and Flash, because reading articles I found that the same happening with Flash also? Please advise.

    Sunday, July 24, 2011 8:16 AM
  • Has any one have this issue resolved? People from Microsoft, we need your help!

    We have a QA machine currently is having the exact same problem: Silverlight crashes in all browsers on any page that contains Silverlight control.  In IE, the page simply just hungs. In FF or Chrome we get Silverlight is crushed message and icon.  The machine was working before. The problem started about two weeks ago and we don't know what triggered it. We tried to uninstall (including make sure Registry, Silverlight file folder are cleaned up), reboot and reinstall many times. The problem just won't go away. 

    One strange thing we found is that the Silverlight install size is only 20.3 MB on this machine under the installed "Programs and Features" list while the size shown in other working machines are >30MB. (Mine shows 32.9MB, But I'm on Developer version). The machine is on Windows7 system.  The Silverlight version is 4.0.60531.0


    We finally figured out the problem with the QA machine.  We checked the System event log on the machine and found Disk Error messages on each Silverlight install event.  The strange thing is that Silverlight install never reported any error.

    Anyway, after swithing getting a new disk on the machine, we no longer have this problem.

    Thursday, September 15, 2011 11:28 AM
  • My sister was having this problem the other day. Come to find out she uses Chrome and her default browser and installed silverlight through it. It crashed all browers even IE9.


    To resolve the problem she unistalled silverlight and then went to IE and installed Silverlight. It is now working on all browsers. Worth a shot to get it to work. Does not leave a good feeling that there are other users with the same problem.

    Wonder if this is a known issue or not.



    Monday, October 03, 2011 5:12 PM