none
Visual Interface: Web service outputs "Scored Probabilities_0" 1, 2, 3,... instead of the labels RRS feed

  • Question

  • I am trying to re-create a multi-class classification model in the Visual interface. In the old ML model the web service would output all the scored labels (classes) and their corresponding probability, and of course the predicted class. In the new model I can't get it to output  the actual class with its probability. All I get in the output is a generic "Scored Probabilities_0" and its probability. But I don't know which class is Scored Probabilities_0, or 1 or 2 etc.. What has changed in the visual interface?
    Tuesday, October 15, 2019 6:29 PM

All replies

  • Hi,

    Thank you for your feedback. I’ve provided this feedback to the product team to update the column names to represent their respective class names in Azure ML Visual Studio. For now, you can consider the names to represent each class (in ascending order). So, for example, as shown in the image below, Scored Probabilities_0 would represent class “1” and Scored Probabilities_1 would represent Class “2”. I will let you know once I get some updates from the team. Hope this helps. Please let me know if you have further questions. Thanks.


    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Friday, October 18, 2019 9:01 PM
    Moderator
  • Thanks. I am afraid with production data we will have around 10,000 classes. Without the output of the actual class name it's unusable. We are planning to retrain every week with potential increase to that number. Having to build an index internally in the calling application for the classes is impractical. I will await your updates before proceeding further.

    Thanks

    Jitendra

    Friday, October 18, 2019 10:45 PM
  • Hi,

    Thank you for this information. I’ve looped in the product team. Can you please send your subscription id to [[AzCommunity][at][Microsoft][dot][com]]? Also, our product team may want to contact you regarding your issue, so please include your contact email as well. Thanks.

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Monday, October 21, 2019 3:39 PM
    Moderator
  • Hi,

    We didn’t receive your email. However, I want to inform you that our product team is aware of this issue, and improvement request has been added to their backlog items. Please reach out to us if you have further questions or concerns. Thanks.

    Regards,

    GiftA-MSFT.

    If a post helps to resolve your issue, please click “Mark as Answer” and/or “Vote as helpful”. By marking a post as Answered and/or Helpful, you help others find the answer faster.  Thanks.

    Thursday, October 24, 2019 7:17 PM
    Moderator