Silverlight Tools Beta 2 for VS 2008 - "Missing Patch" error


  •  I started with a brand new formatted machine, fresh install of Vista, so it doesn't have any remnants of earlier Silverlight bits.  Installed s/w in this order:

    • Vista
    • IIS
    • VS 2005, including Team Explorer, sp1, extensions for WCF, WPF, WF
    • Office 2007
    • .NET 3.5
    • Windows SDK 6.1
    • VS 2008 Team System (developers), including Team Explorer
    • VS 2008 sp1
    • Silverlight Tools Beta 2 for VS 2008  (silverlight_chainer.exe  published 8/11/2008)

    When opening or creating a Silverlight project, I continue to get the famous error:

     "Microsoft Silverlight Tool is unable to open the project due to a missing patch for Visual Studio." 

    Download link takes me to the same silverlight_chainer from 8/11/2008 download that I've been running.  (here)

    Since this is on a fresh machine, it shouldn't be related to having previous beta versions installed.  

    Any ideas on what to try, or what's wrong with my installation order above?

    Thanks in advance!


    Sunday, September 07, 2008 10:58 PM

All replies

  • Did you run the chainer after installing VS SP1?

    Sunday, September 07, 2008 11:06 PM
  • Oops - yes, I did.  Sorry, had those 2 reversed in the original post.  (Updated the original post to reflect reality)

    Have even re-run the VS 2008 SP1 and then silverlight chainer again after that.  Still same error.

    Sunday, September 07, 2008 11:38 PM
  • What are the file versions for %programfiles%\Microsoft Visual Studio 9.0\Common7\IDE\Microsoft.VisualStudio.Web.Application.dll and %programfiles%\Microsoft Visual Studio 9.0\Common7\Packages\mswebprj.dll?

    Monday, September 08, 2008 12:05 AM
  • Microsoft.VisualStudio.Web.dll    9.0.30729.1    07/30/08

    mswebprj.dll    9.0.30729.1    07/30/08


    Monday, September 08, 2008 12:09 PM
  • Sorry for the delay (things have been pretty intense lately at work).

    Can you try installing just the patch?  Here's some instructions:

    • Extract the contents of the chainer to a directory using the command: 'silverlight_chainer.exe /x:<some Directory>'
    • Look in the extracted contents for a file called VS90SP1-KB945214.msp and run that

    Let me know how it goes.

    Wednesday, September 10, 2008 12:11 PM
  • Thanks for the reply / suggestion.

    I ran the .msp and the first time got the following error in a MessageBox: 

    Error 32003: File C:\program files\Microsoft Visual Studio 9.0\Common7\Tools\vsvars32.bat  could not be opened for write.

    Figuring this was about UAC and no access to Program Files, I ran the .msp again, this time from a cmd prompt running as administrator.  This time it finished without errors.

    However, still when I open a Silverlight project in VS 2008, I get the same error:

     Microsoft Silverlight tools is unable to open the project due to a missing patch for Visual Studio. 

    Thursday, September 11, 2008 2:33 PM
  • Sorry again for the delays.

     Can you package together the install log for the patch and for the chainer and send them to me at: jamlew (AT) microsoft (DOT) com.  The log file for the chainer should be called something like 'Silverlight Beta 2 Chainer_<date>_<time>.html'.  For the patch, please run the patch from the command line like this: Path\To\Patch> msiexec /L*vx <SomePathToSaveLogFile>\patchLog.log VS90SP1-KB950730.msp.

    - Jimmy Lewis

    Friday, September 12, 2008 5:46 PM
  • I sent you an email to the above address. 

    I ran the chainer, sent you the log.  I dont have the exact MSP that you mention, tried to run the SP1  msp that's in my extracted directory and cant get the params right for the *vx logging.  MSIEXEC throws up the command line help dialog.


    Tuesday, September 16, 2008 5:55 PM
  • Some users have experienced issues with downloading a cached version of the tools installer.  The download should be signed on 8/1/2008 and should install KB955214.  The correct version of the installer is available here (as with any .exe you download from the Internet, verify that it was digitally signed by a trusted source before installing). 

    Sunday, September 21, 2008 9:15 AM
  •  Hi you can try this link for getting silverlight  2.0


    Monday, September 22, 2008 7:09 AM
  • I had heard that before and validated that my installer is in fact signed on 8/1/2008 and contains KB955214.  I have sent the logs to jamlew and we're working through a couple options.

    Will post back here with any successful results to help others with the same problem.


    Monday, September 22, 2008 1:05 PM
  • I'm getting the same problem and I've just installed VS2008 + SP1 for the first time today.

    Monday, December 22, 2008 2:13 PM
  • Even with the MS guys helping by combing my 16 MB of log files, they couldnt come up with anything specific to try to get around this.  Ended up re-paving my machine, and this next time I installed, everything installed and is functioning correctly.

    There are 2 differences in the set of software I installed on that next go-round:

    • No VS 2005
    • No Windows SDK  
    I have no way of knowing if those are the culprit (not enough machine rebuilds with and without them). The MS guys said neither of those should have any impact on the successful installation and function of Silverlight tools, but you never know. 

    Sorry cant be of much more help.
    Monday, December 22, 2008 11:20 PM
  • volleynerd, for my notes, what version of the Win SDK did you have installed previously?  I didn't encounter any issues when I tried with 6.1, or with VS 2005, but I'll can also try a different Win SDK version to make sure.  Thanks. Smile

    Saturday, December 27, 2008 3:02 AM
  • I had installed the 6.0 version of the SDK I think.  Here's the file name, which shows what version.

    Windows SDK .NET 3.5 6.0.6001.18000.367-KRMSDK_EN


    Tuesday, January 20, 2009 11:20 PM