none
[Automated ML][UI] Failed Experiments RRS feed

  • Question

  • HI there

    I constantly get failed experiments using the Automated ML UI.  The error are as follows:

        c/_cffi_backend.c:15:17: fatal error: ffi.h: No such file or directory    compilation terminated.    error: command 'gcc' failed with exit status 1    ----------------------------------------ERROR: Command errored out with exit status 1: /azureml-envs/azureml_5baab5df050a3bee9b0428971d07cbe5/bin/python -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-xk4wflyf/cffi/setup.py'"'"'; __file__='"'"'/tmp/pip-install-xk4wflyf/cffi/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-szpi8j5c/install-record.txt --single-version-externally-managed --compile Check the logs for full command output.CondaValueError: pip returned an error

    Is this something I am doing wrong in the setup?

    Paul

    Tuesday, October 15, 2019 9:59 AM

All replies

  • Yup, I get that too when trying to create images with pip dependencies. Seems to have started yesterday, I'm currently looking into this but it really looks like an Azure error.

    Update: Looks like it's caused by having the following pip dependency:

          - azureml-sdk[automl]

    If we just include azureml-sdk, without the automl package, everything works as expected.
    Tuesday, October 15, 2019 12:27 PM
  • As suspected, there seems to be an issue with the latest version of the SDK. I've had success in running the previous version - 1.0.65. You can pin that version by updating your conda file, as follows:

      - pip:
          - azureml-defaults==1.0.65
          - azureml-sdk[automl]==1.0.65

    Tuesday, October 15, 2019 5:39 PM