locked
Message ID: 1603 RRS feed

  • General discussion

  • Running Vista 64bit.

    I have had beta and RC versions of SL installed, but cannot install the full release version.

    I have uninstalled everything, VS tools etc etc.  I have even now uninstalled expression studio.  I have checked updates section to ensure everything is gone...

    I still however get the error above at 99%.

    I get linked off to this page. https://www.microsoft.com/silverlight/resources/help.aspx?errorID=1603

    Friday, February 13, 2009 10:34 AM

All replies

  • Hi SteveClements,

    We suspect that Silverlight is completely uninstalled from your machine.  Please first close all your browsers and then uninstall it from your Control Panel.

    Also, we suggest that you'd better check my replies on this thread.

    Best regards,

    Jonathan

    Tuesday, February 17, 2009 9:42 PM
  • I've done all suggested, but still problems.

    After the cleanup i tried to install silverlight again, but no joy.  So I tried to install Silverlight tools for vs 2008 sp1 and got a fatal error, this being the error bit from the log

    Created new ExePerformer for Exe item

    [2/18/2009, 9:21:5] (IronSpigot::ExeInstallerBase::Launch) Launching CreateProcess with command line = Silverlight.2.0_Developer.exe /q /ignorewarnings
    [2/18/2009, 9:21:13] (IronSpigot::ExeInstallerBase::PerformAction) C:\Users\STEVE~1.CLE\AppData\Local\Temp\Silverlight Tools RTW\Silverlight.2.0_Developer.exe - Exe installer does not provide a log file name
    [2/18/2009, 9:21:13] (IronSpigot::ExeInstallerBase::PerformAction) Exe (C:\Users\STEVE~1.CLE\AppData\Local\Temp\Silverlight Tools RTW\Silverlight.2.0_Developer.exe) failed with 0x80070643 - Fatal error during installation. .
    [2/18/2009, 9:21:13] (IronSpigot::ExeInstallerBase::PerformAction) PerformOperation on exe returned exit code 1603 (translates to HRESULT = 0x80070643)
    [2/18/2009, 9:21:14] Action complete
    Wednesday, February 18, 2009 4:30 AM
  • Hi Steve,

    Please navigate to C:\Users\STEVE~1.CLE\AppData\Local\Temp and delete all the files located inside Silverlight Tools RTW folder.  Then re-download the installation file and run it under the Administrator account. Please let me know the result.

    Best regards,

    Jonathan

    Wednesday, February 18, 2009 6:53 AM
  • I am having the same problem with no luck using the previous remedies

     

    MSI (s) (A0:FC) [11:46:51:393]: Transforming table RemoveRegistry.

    MSI (s) (A0:FC) [11:46:51:393]: Note: 1: 2262 2: RemoveRegistry 3: -2147287038
    MSI (s) (A0:FC) [11:46:51:397]: Note: 1: 2205 2:  3: Condition
    MSI (s) (A0:FC) [11:46:51:397]: Machine policy value 'EnforceUpgradeComponentRules' is 1
    MSI (s) (A0:FC) [11:46:51:398]: SELMGR: ComponentId '{3F1B4729-57DD-4DD2-B687-ED22629260E0}' is registered to feature 'Complete', but is not present in the Component table.  Removal of components from a feature is not supported!
    MSI (s) (A0:FC) [11:46:51:398]: Note: 1: 2771 2: Complete
    MSI (s) (A0:FC) [11:46:51:398]: Note: 1: 2205 2:  3: Error
    MSI (s) (A0:FC) [11:46:51:398]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 2771
    Action start 11:46:51: CostFinalize.
    DEBUG: Error 2771:  Upgrade of feature Complete has a missing component.
    MSI (s) (A0:FC) [11:46:51:400]: Note: 1: 2205 2:  3: Error
    MSI (s) (A0:FC) [11:46:51:400]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709
    MSI (s) (A0:FC) [11:46:51:400]: Product: Microsoft Silverlight -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2771. The arguments are: Complete, ,

    MSI (s) (A0:FC) [11:46:51:402]: Transforming table InstallExecuteSequence.

    MSI (s) (A0:FC) [11:46:51:403]: Transforming table InstallExecuteSequence.

    Action ended 11:46:51: CostFinalize. Return value 3.
    Action ended 11:46:51: INSTALL. Return value 3.
    MSI (s) (A0:FC) [11:46:51:405]: Product: Microsoft Silverlight - Update 'Microsoft Silverlight 2.0.40115.0' could not be installed. Error code 1603. Additional information is available in the log file C:\Users\RHORNE~1.NUA\AppData\Local\Temp\SilverlightMSI.log.

     

    Any ideas?

    Thursday, March 5, 2009 11:41 AM
  • I think you may have something installed that is blocking the delete and re create of registry keys??

    Thursday, March 5, 2009 11:50 AM