"The feature you are trying to use is on a network resource that in unavailable"


  • I'm trying to upgrade from Silverlight 4 (4.0.50524.0) to the latest version.
    Upon downloading and running the setup, I get the following error: 

    Searching for the "silverlight.msi" comes up with this:

    Manually selecting this file gives me this error:

    At this point I can only cancel out, in which the installer points me toward - which doesn't give any info other than uninstalling/reinstalling.

    So, I try uninstalling, but end up with:

    This time, no silverlight.msi can be located on my computer.

    Any help would be very much appreciated ;)
    Thanks, Pigophone. 

    Sunday, April 22, 2012 11:21 AM


All replies

  • Hi,

    Try download Silverlight runtime directly. There are two, Silverlight.exe and Silverlight_x64.exe. You can download from and respectively.

    Have fun.

    Sunday, April 22, 2012 5:28 PM
  • I'm havig the same problem. Silverlight has a security update... The many links to downloands aren't helping, I get the same error message. Unistalling also gives me the same "The feature you are trying to use is on a network resource that is availiable" error message. I tried removing all the files and still get the same error message. Any insight would be helpful, thanks.

    Thursday, April 26, 2012 5:47 PM
  • I get the same thing as well, can't remove and can't install.  Why do I need Silverlight anyway?  Because some site says I need to use it to view thier stuff?  I guess they need to find something better for displaying things than this.

    Thursday, April 26, 2012 8:05 PM
  • Hi,

    Please try with below fixit to uninstall silverlight and then download and install it again.


    Best Regards,

    Thursday, April 26, 2012 10:18 PM
  • I just ran the fix it program and installed the update. This worked great thank you.
    • Proposed as answer by regs79 Thursday, July 30, 2015 12:45 PM
    • Unproposed as answer by regs79 Thursday, July 30, 2015 12:45 PM
    Wednesday, November 13, 2013 5:18 PM
  • Just create whith notepad a CleanSilverlight.cmd file whit the code below and execute as administrator and than reinstall Silverlight:

    reg delete HKLM\Software\Microsoft\Silverlight /f
    reg delete HKEY_CLASSES_ROOT\Installer\Products\D7314F9862C648A4DB8BE2A5B47BE100 /f
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\D7314F9862C648A4DB8BE2A5B47BE100 /f
    reg delete HKEY_CLASSES_ROOT\TypeLib\{283C8576-0726-4DBC-9609-3F855162009A} /f
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\install.exe /f
    reg delete HKEY_CLASSES_ROOT\AgControl.AgControl /f
    reg delete HKEY_CLASSES_ROOT\AgControl.AgControl.5.1 /f
    reg delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{89F4137D-6C26-4A84-BDB8-2E5A4BB71E00} /f
    rmdir /s /q "%ProgramFiles%\Microsoft Silverlight"
    rmdir /s /q "%ProgramFiles(x86)%\Microsoft Silverlight"
    Thursday, July 24, 2014 1:51 PM