none
Timestamp Code signing with EV certificate not working in VSTO RRS feed

  • Question

  • Currently i am facing an issue in code signing with VSTO Addin.
    Issue is, After code singing certificate is expired VSTO Addin showing following error while loading .

    System.Security.SecurityException: The solution cannot be installed because it is signed by a publisher whom you have not yet chosen to trust. If you trust the publisher, add the certificate to the Trusted Publisher list.

    To solve the issue, i have  timestamped the code along with code signing.Still showing same error.(I have tested by changing the system clock to future for making expiry of certificate).

    Initially i tried by timestamping the code using Visual Studio  signing  option.
    Also i tried by various other tools like siginTool, mage etc.still it showing the same error.

    I also tried by signing all associated dlls ,still same result.
    However when i have created a test certificate locally and do code signing, time stamping working perfectly,Addn loaded normally.

    Any idea? Please help.

    Thanks in advance.


    Tuesday, July 7, 2020 11:27 AM

All replies

  • It seems your certificate could not be recognized as trusted. You import the test certificate into trusted root and trusted publisher store.

    Also you may find similar forum threads helpful:

    Untrusted Publisher error with VSTO Add-In

    Unable to run Excel VSTO Add-ins


    profile for Eugene Astafiev at Stack Overflow, Q&A for professional and enthusiast programmers

    Tuesday, July 7, 2020 1:54 PM
  • Astafiev,

    Thank you very much for sharing the information.

    I have already tried by importing original digicert EV certificate to trusted root and trusted publisher store. Still the same result.

    The problem is occurring only when the certificate  is expired.Other wise working normally and Addin loading successfully.

    Any idea about this?

    Thanks in advance.

    Regards ,

    Ras

    Tuesday, July 7, 2020 4:49 PM