none
Visual Studio 2017 Installer Crashes on Start up RRS feed

  • Question

  • Hi,

    When I try to install VS 2017 community edition, the installer crashes as soon as i start the installation.

    Error: Visual studio installer has stopped working.

    Can someone help me figure out the issue.

    Also the SQL server management studio crashes after starting up. 

    I am using Windows 10.

    Thanks

    Tuesday, April 17, 2018 11:52 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    Please check if the following file exists on your machine?

     "C:\Program Files (x86)\Microsoft Visual Studio\Installer\resources\app\renderer\Events\LocaleSelectedEvent.js"

    If the file does not exist, the installer is corrupted. To work-around this, you can

    • Delete "C:\Program Files (x86)\Microsoft Visual Studio\Installer" folder
    • Download and run vs_community.exe from https://visualstudio.com/vs again.

    If the issue persists, please use http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.zip under %temp% folder. Please upload the file to https://onedrive.live.com/ and share the link here.

    Besides, check the log in event viewer in your computer.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, April 18, 2018 4:09 AM
  • Hello Joyce,

    I have also the same issue on my computer. I have tried things that you explain above. However, my problem is continuing. Then, I shared that you mentioned via one drive.
    Could you help me to solve this questions?

    link: https://onedrive.live.com/?cid=907495359726C478&id=907495359726C478%21657&parId=root&o=OneUp

    Thank you,

    İrem Nur Dukan.


    • Edited by iremnd Monday, December 10, 2018 4:24 PM
    • Proposed as answer by iremnd Wednesday, December 12, 2018 12:53 PM
    • Unproposed as answer by iremnd Wednesday, December 12, 2018 12:53 PM
    • Proposed as answer by iremnd Saturday, December 22, 2018 10:06 AM
    Monday, December 10, 2018 4:23 PM
  • Hi!

    I had the same problem, and what eventually worked was to move the installation file to "C" hard drive and run it from there .... works like magic

    Saturday, November 2, 2019 10:56 AM