locked
identity provider 'live.com' does not exist in tenant 'OsTechnology' RRS feed

  • Question

  • In the getting started docs, a document is linked to that gives a 404:
    https://docs.microsoft.com/en-us/azure-sphere/quickstart/qs-azure-directory-account

    I believe this is the step I must perform to be able to login to: 

    >azsphere login

    The error I get is:

    AADSTS50020: User account 'XXX@outlook.com' from identity provider 'live.com' does not exist in tenant 'OsTechnology' and cannot access the application 'xx-xxx-xxx-xxx-xxx' in that tenant. The account needs to be added as an external user in the tenant first. Sign out and sign in again with a different Azure Active Directory user account.

    Deleting the json file did NOT work as described here: https://social.msdn.microsoft.com/Forums/en-US/ec19de7d-ed73-4103-a36e-6492eb1d80ed/cannot-claim-device?forum=azuresphere

    I did find a page that talks about an Azure Directory Account (https://docs.microsoft.com/en-us/azure-sphere/install/azure-directory-account) that says I need an account with AAD. I do everything Azure through my personal account. My account seems to have a tenant already assigned in <name>.onmicrosoft.com, but when I look at the AAD license I dont have any.

    I tried to followed these directions:

    https://docs.microsoft.com/en-us/azure/active-directory/develop/quickstart-create-new-tenant

    It took a while for the tenant to show up so I could link it (it is odd that it is two steps). This didn't work as my user still did not have the AAD assignment.

    I thought I might have to activate a license. I want to activate a free license, but the free license does not show on my primary account and the License section is disabled in the tenant I created.

    It seems there is a hole in the documentation that I have gotten hung up on. I just want to add my regular account to a free tier AAD.
    • Edited by ac_4 Saturday, September 29, 2018 4:52 AM
    Saturday, September 29, 2018 3:52 AM

All replies

  • Do you use work account? (i.e. xxx@yyy.onmicrosoft.com)
    Is source 'Azure Active Directory' in All Users in Azure Active Directory?
    
    Saturday, September 29, 2018 7:43 AM
  • I have only one account. I have tried to login with xxx@outlook.com and xxx@yyy.onmicrosoft.com. The second does not exist.

    I am not clear on what you are asking on the second question.

    thank you for your reply


    • Edited by ac_4 Saturday, September 29, 2018 4:07 PM
    Saturday, September 29, 2018 4:06 PM
  • Please check this:

    1. xxx@outlook.com and xxx@yyy.onmicrosoft.com account exist in yyy.onmicrosoft.com Azure Active Directory.
    2. See xxx@outlook.com is Microsoft Account and xxx@yyy.onmicrosoft.com is Azure Active Directory in All Users in Azure Active Directory. ( image )
    3. Execute 'azsphere login' and use xxx@yyy.onmicrosoft.com account .


    Sunday, September 30, 2018 1:14 AM
  • See also the following guidance: https://docs.microsoft.com/en-us/azure-sphere/app-development/limit-tenant-access

    Are you Global Administrator or Application Administrator for the directory ?

    Tuesday, October 2, 2018 4:56 PM
  • i encountered the same issue , here is how i fixed it.

    logon to your AAD with your external account 'XXX@outlook.com' 

    create a new AAD user like : admin-sphere@<yourtenant>.onmicrosoft.com

    then promote this new account as an admin of your AAD

    then execute azsphere login with this new user identity.

     


    Saturday, October 6, 2018 3:25 PM
  • You all might as well be speaking Klingon. I am a real estate guy and "tenant" means something completely different where I come from. I have no idea what any of you are talking about but Microsoft keeps asking me to login every day and then tells me my tenant doesn't belong in this house.

    Think you guys to dumb it down about 50 levels so a non-programmer could follow some simple steps to solve whatever problem Microsoft is having with me using my computer?

    Tuesday, April 7, 2020 8:43 PM