• When I go to the Microsoft web page the page says "install Silverlight now for a better Web experience" INSTEAD OF THE CURRENT VERSION OF SILVERLIGHT INSTALLED ON MY COMPUTER.  So I click the big blue button "CLICK TO INSTALL" and go through the routine and when it's finished it says "THE SAME VERSION OF SILVERLIGHT IS ALREADY INSTALLED".  Now when I refresh the web page  it is supposed to check and display the current version, NOT A REPEATED MESSAGE OF "Install Silverlight now for a better Web experience" and further display a large blue button saying "CLICK TO INSTALL" once again. 
    For some unknown reason, IE8 is not recognizing Silverlight being installed or Silverlight is not registering properly in IE8 (I don't know which) and always loads the same message CLICK TO INSTALL.  I have tried multiple times of uninstalling from Control Panel and rebooted but makes no difference.  With regard to enabling Silverlight in add-ons, please note that Silverlight is NOT in the list of "Currently loaded add-ons" but IS in the list of "Run without permission" when I go to the Silverlight web page.  My browser is IE8.  Also note Silverlight IS recoginzed and displays version in Firefox--ironic a Microsoft product would function properly in Firefox but not in IE8. 
    Need help please.
    Friday, December 24, 2010 1:51 PM

All replies

  • Hi. Are you using the 64-bit version of Internet Explorer? There is no 64-bit runtime of Silverlight, so please use the 32-bit version.

    Friday, December 24, 2010 3:44 PM
  • Not to 64 bit, using 32-Bit Windows Vista.  Nice try but also have another machine with 64-bit Windows Vista and no issues at all however.

    Friday, December 24, 2010 4:34 PM
  • Monday, December 27, 2010 3:15 AM
  • Having the same problem. 32 bit XP 32 bit IE7. Tried removing reinstalling via control panel. Tried to remove "extrainious files" via instructions using regedit, no files/entries existed to remove. Tried going into Tool manage and silverlight isnt listed. Tried going into internet options, advanced, browser and unchecking 3rd party.  What do I try next. Has anyone solved this problem?

    Tuesday, March 22, 2011 11:57 AM
  • Had same problem with Win 7 64-bit after installing IE9 and new version of Silverlight was required for MSN Portfolio.

    Emailed Microsoft and was surprised that they even responded. Was given a few half-baked solutions including running utility to clean up registry, etc. None worked.

    Didn't have time to fool around any longer so I just restored the PC to earliest restore point I could (which was about 2 weeks ago). Afterwards all updates were OK: IE9 and Silverlight.

    Wednesday, March 23, 2011 5:04 PM
  • Go with the Firefox browser instead of Internet Explorer you'll not have anymore problems with Netflix, xfinity or any video. I have IE and Firefox side by side on my Quick Launch. Over time I've completely weaned away from IE. Firefox is just as good.

    Thursday, August 11, 2011 7:30 PM
  • Troubleshooting silverlight not installing:

    1. Firstly, note whether you are on 32bit OS or 64 bit OS.
    2. Then if you are on 64bit have a look at this directory C:\Program Files (x86)\Microsoft Silverlight,
    3. otherwise look at this C:\Program Files\Microsoft Silverlight
    4. There should be one directory and two files in there
      1. 4.0.60531.0
      2. sllauncher.exe
      3. xapauthenticodesip.dll
    5. Run another browser say Firefox, to establish whether the fault is in the Silverlight installation or in Internet Explorer. If Silverlight works in Firefox then the fault is in Internet Explorer.
    6. Restore your internet explorer to factory settings
    7. In Internet Explorer: Manage AddOns - make sure Microsoft Corporation - Microsoft Silverlight is enabled. (The previous step should have taken care of this for you).

    If trouble persists, refer to Silverlight Deployment Guide. It has detailed troubleshooting steps.

    Thursday, August 11, 2011 9:28 PM
  • I have been having this same problem and it was causing issues with my Office 365 account as well.

    The probelm was a security permissions issue caused by the Silverlight installer. The folder C:\Program Files (x86)\Microsoft Silverlight was not owned by anyone, nor did any user have permissions to the folder or files beneath.

    1. Browse to C:\Program Files (x86)\Microsoft Silverlight
    2. View the security permissions -   Right-click, Properties, Security
    3. Take ownership
    4. Then change security permissions by adding yourself as a user with FULL control of the folder and the sub-folder and files.

    You should then be all set.  You can also now reinstall Silverlight, although I did not need to do this once I fixed the above.

    Good luck!

    Friday, August 12, 2011 5:10 PM
  • Resetting IE to default (without clearing the home page etc.) fixed the issue for me.  Thanks!
    Wednesday, January 18, 2017 7:04 PM