This is killing me, been using netflix for as long as I can remember, windows 7 - 8

    Something changed in the past couple of days, because it crashes (goes black, no audio, have to stop plugin ON ALL BROWSERS!!)

    I've uninstalled, cleaned reg, reinstalled, uninstall browser, everything you can think of

    Windows 8

    Silverlight 5

    Need help, having to reset netflix each time is ruining it

    Wednesday, January 01, 2014 7:25 AM


All replies

  • Hi,

    According to your description, I am not sure whether Silverlight cause the issue. Did it throw any error message when it was wrong? If so, please provide us with it. Based on my experience, you may try the methods below:

    In addition, I'd like to suggest you to post the issue on Netflix Help Center to get help from another aspect.

    If you need further assistance, please let me know.

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, January 02, 2014 2:40 AM
  • I am also experiencing issues with silverlight. If badly effects netflix and on occasion facebook. While trying to watch netflix, it will be fine for a bit then suddenly it'll freeze firefox up as well as completely bog down my poor laptop, sucking up 100% cpu. And I also have for a whole been getting different unresponsive script messages, including for silverlight. Before the newest few versions of firefox and silverlight, netflix ran just fine. What happens with netflix. Will act up but return to playing. Then suddenly locks up, sucking all cpu/memory. Firefox will also randomly "jump" and also go Not Responding then not. I end up having to wait for my computer to catch up to my clicking the X to close or manual shit down with power button. The jumping has also happened a few times while viewing facebook. A reinstall of silverlight fixed that but not the najor issue with netflix. HD is also turned off on netflix (poor old laptop cant handle it). This is driving me nuts!! O.o Win7 up to date Firefox 28 (just updated as of this posting) Silverlight 5
    Friday, March 28, 2014 5:34 AM
  • It is now August and this problem still is here. I have uninstalled and installed a gazillion times. It is nothing wrong with our computers or Netflix. For all these Millions of people to be having the same problem on many different computers and no matter if you are using IE, Chrome, Firefox or what ever, it is still happening. Can you guys please find a fix for your program so I don't waste my hard earned money. You pay for netflix and half of the time I cant watch it because of the whole silverlight issue. PLEASE FIX THIS!
    Monday, August 04, 2014 8:12 PM
  • I know this is old but to anyone reading this:

    I found these steps on the Netflix website and it seems to have solved my problem! 

    1. Quit all open browsers - including this window! You may want to print/copy the following steps.
    2. Press and hold the Windows key and tap the letter R on the keyboard at the same time. This displays the Run window.
    3. Type %userprofile%/appdata and select OK.
    4. Open the LocalLow folder.
    5. Open the Microsoft folder.
    6. Open the Silverlight folder.
    7. Right-click on the is folder and select Delete.
    8. Reopen browser and Netflix should work.

    Hope it works for you too!

    Saturday, August 30, 2014 8:52 PM
  • Thank you so much!
    Tuesday, September 23, 2014 2:17 PM
  • nope. i am having the same issue i deleted the 'is' folder after closing my browser and when i re-opened it, still the same 'Silverlight Plug-In has crashed' any other advice? 

    • Edited by BushBG Saturday, October 04, 2014 9:09 PM
    Saturday, October 04, 2014 9:09 PM
  • I use Firefox and had the same problem.  Go into settings and disable "hardware acceleration".

    Edit: Nevermind.  The problem is still there.
    • Edited by Shadocat Tuesday, October 21, 2014 8:10 PM
    Friday, October 17, 2014 6:34 PM
  • I have reinstalled Silverlight several times, and even tried using dedicated browsers for Netflix. Nothing worked until this post. Thanks stranger!
    Sunday, November 09, 2014 12:04 AM
  • I now get Netflix error N8152with the Sliverlight 5 update.  Talked to Netflix support they suggested Chrome or any other browser that is HTML 5 compatible. Dose MS have a fix available for Sliverlight 5. I really don't want to put another or outdated browser on my pc.
    Wednesday, December 10, 2014 5:23 PM
  • I now get Netflix error N8152with the Sliverlight 5 update.  Talked to Netflix support they suggested Chrome or any other browser that is HTML 5 compatible. Dose MS have a fix available for Sliverlight 5. I really don't want to put another or outdated browser on my pc.

    Same, here. I'll add that I believe this to be a failure with the most recent update to Silverlight:

    Yesterday, Netflix worked fine. I installed updates before going to bed - one of which was an "important" update for Silverlight - and today Netflix says that there is an error (N8152), pertaining to the previously-mentioned program.

    When going into the Installed Updates list and attempting to uninstall (like you're SUPPOSED to be able to do, for just such occasions as this), the Silverlight update gives no options to do anything.

    Resorting to an uninstall, I then found that I was unable to RE-install; despite the fact that I am running a 64-bit version of Vista, the installation program claims that it is 32-bit, and therefore will not install (there is no option to select a different version of the program).

    From the looks of the forums here, this is not the first time this problem has occurred; many of these threads are years old, yet have the same issue stated - the EXACT same issue - every single detail.

    Seriously, Microsoft? This seems to have happened at LEAST twice before now, possibly more (I haven't paid the closest attention to all the dates on the posts), and you've messed it up yet again?


    There have been several fixes posted on the aforementioned old threads, so I'm going to give those a shot. I'll post here again if at least one of them is still applicable. I think someone posted a link to the 32-bit version, so I'll likely give that a shot, first.

    Thursday, December 11, 2014 4:02 AM
  • I only consider this temporary, as it's technically running an... "inferior"? version of the program, but here's a link to the 32-bit version of the program. If you are running 64-bit, like me, then your problem sounds identical, and uninstalling your current version of Silverlight before installing the below version should fix it for you.

    I haven't checked any of the other proposed fixes in other threads, since the first try worked and this was the least effort. Netflix works again - and that's all I care about for now.

    Thanks to Shi Ding ( for posting this link back in 2011 when the exact same problem popped up.

    (I'd have turned those links into click-ables, but I just created this account, and apparently Microsoft doesn't trust me to not lead you guys to shock-sites or something. :P )
    • Edited by KrysRocks Thursday, December 11, 2014 4:19 AM Added link to a user's page.
    • Proposed as answer by KrysRocks Thursday, December 11, 2014 4:19 AM
    Thursday, December 11, 2014 4:17 AM
  • I've found the Opera browser works best with Netflix. Still crashes now and again but just closes it and re-open and it works again.

    Friday, March 20, 2015 11:37 PM
  • Actually I believe it is not the Netflix, It is not the browsers. Its a glitch in the drivers for your video card. I have total 7  machines I use Netflix on. 4 laptops, three desktops. All six and not to mention smart phones, android or apple work great but one. My HP Xw8400 with TWO nVidia Qaudro cards. Netflix or silverlight has no issues if I run the cards with Microsoft WDDM drivers. As soon as I upgrade the drivers to nVidia,  Netflix and Silverlight start having problems. 

    Its on Windows 7 64bit driver version 309.08.

    I must add; I also had same problems with VLC player too. I had to in advance settings in VLC player to make necessary adjustment and it works great.

    • Edited by JazzMemo Thursday, July 02, 2015 8:24 PM
    • Proposed as answer by bigd0311 Saturday, October 03, 2015 5:01 PM
    Thursday, July 02, 2015 8:12 PM
  • Thanks, Jazz.

    Installing the latest Nvidia drivers fixed the problem.

    Saturday, October 03, 2015 5:01 PM