latest silverlight update broke netflix


  • Netflix streaming stopped working for me after the latest silverlight update (4.0.60310.0). Before that it had been working fine. After the update, however, trying to watch a video on netflix crashes my entire computer. The mouse pointer stops moving, alt-tab doesn't work, ctrl-alt-delete does nothing. I have to hold the power button down to shut off the computer.

    I've tried this both in IE and chrome; both exhibit the same crash.

    I tried uninstalling silverlight and reinstalling the latest version, it still crashes. I thought I would try uninstalling a 2nd time, but found out that I'm no longer able to uninstall silverlight. When I do, I get an error dialog that says "No valid sequence could be found for the set of patches."

    So now I have two problems: silverlight crashes my computer when I try to watch netflix, and I'm unable to uninstall silverlight.


    This is on an Asus u30jc laptop running win 7 64-bit. 

    Monday, May 23, 2011 11:12 PM


All replies

  • I have some more details after working on this for a couple more hours:

    • also causes my computer to crash.
    • plays fine for me.
    • I have tried the current version of silverlight (4.0.60310.0), the beta release of silverlight 5, and the previous two versions of silverlight (4.0.60129.0, 4.0.51204.0). All of them crash when I try to play netflix or the drm sample linked above.
    • I haven't been able to find anything helpful in the event logs

    What can I do? 

    Wednesday, May 25, 2011 1:32 AM
  • Hi,


    I did some searches and found this info for the error is Windows installer error


    "No valid sequence could be found for the set of patches."





    No valid sequence could be found for the set of patches. Available beginning with Windows Installer version 3.0.


    Manually Remove/Uninstall Silverlight



    How to fix Silverlight upgrade errors on Netflix

    Thursday, June 02, 2011 11:03 AM
  • I had the exact same problem after my Silverlight plugin got updated to version 4.0, but I fixed it! Here's how:

    1. Make sure you use Google Chrome.

    2. Go to and download Silverlight 3.0, BUT BEFORE YOU DO THAT, uninstall Silverlight 4.0 from your computer by going to Control Panel > Add/Remove Programs, and remove Silverlight there. Silvelight 3.0 won't install if you have a newer version of it already installed.

    3. After you install 3.0, open Netflix on Google Chrome and select a film to watch instantly. You'll get an annoying message saying that you must update Silverlight to 4.0, but instead of doing that, navigate one page back and click on the movie that you wanted to watch again. You should be back on the viewing page, but now, instead of the upgrade message, you should have a grey screen that says "The Silverlight plugin is out of date." At the top of your screen, you should have an orange bar with two buttons, "Upgrade plugin" and "Run this time." Click "run this time," and there! You should be good to go, watching movies without any pauses and crashes in streaming (although the picture quality will not be what it used to be).

    I hope this works for you, and if you know anyone else who has this same problem, spread the word, because frankly, Silverlight 4.0 should get flushed down the toilet. 

    This also may be helpful: I'm using Windows XP, so if you are using something else, I'm not sure if it'll work, but it's worth a try. Good luck!

    Saturday, June 25, 2011 9:52 PM
  • I had the silverlight 5.0 and it still did the same crashes and freezes. I did what you said and downgraded to silverlight 3.0 and netflix wont let me what them. So i did what you said and the yellow bar never showed up. I dont know what to do

    Tuesday, June 12, 2012 4:47 PM