Always have to install twice?


  • I noticed this problem with the original Alpha and now with the 1.1 Alpha Refresh. I always have to install the alpha twice to get it to work.

    I do the install from the application page (graphic that directs me to the 1.1 download at MSFT). I restart the browser as prompted. No other browser windows are open. iexplore doesn't show up in the task list at all. When I come back, I get prompted to install again. No silverlight 1.1 apps work. So, I install it again, and close the browser.

    Then, everything works.

    I have had this problem on my PC (XP Pro) and my wife's laptop (XP Media Center) on both the MIX Alpha and the Alpha Refresh.

    Anyone else having this problem?

    As an aside, I really hope the "restart your browser" bit goes away. That's a huge turnoff for most users, especially since they may not realize (assuming this is true) that you need to restart all browser instances. I'm really REALLY hoping that's an artifact of the alpha, and won't be there in the production 1.1 version. To add a little whine: "flash doesn't make me do that" :) (in fact, no plugins I have used make me restart the browser)


    Sunday, July 29, 2007 12:35 PM

All replies

  • i have asimilar problem as for me no matter how many times i re install it doesnot work. iam using windows server 2003.

    Tuesday, July 31, 2007 5:32 AM
  • I'm also facing the problem. I'm always redirected to download silverlight runtime, even if I already have it.

    Tuesday, July 31, 2007 7:48 AM
  • i think i found a solution but not a professional one. install blend2 August preview create simple project with a text block. guess what it works. then re open it from visual studion and have fun its working now .

    Tuesday, July 31, 2007 8:53 AM
  • If you install the latest Silverlight 1.0 RC and then try to view a Silverlight application that has not been updated, you will continue to see the icon asking you to upgrade.

    Also, if it tells you to close your web browser and you have Microsoft Outlook opened you have to close that too for the update to take properly.

    Tuesday, July 31, 2007 9:05 AM
  • This was all 1.1 stuff. The machines did not have 1.0.  The same problem happened with the original 1.1 MIX bits and the alpha refresh. The scripts were updated appropriately - it's an install issue.

    Outlook was not open on one of the machines. I couldn't find anything that could be using Silverlight. The install took after the second time in all instances, without closing any additional applications. Based on the behavior, there was probably something up and running, but if I couldn't find it, end users don't stand a chance.

    We're still in Alpha, so I expect quirks like this. I just want to make sure this issue is on the radar for a strong resolution prior to 1.1 RC/RTM. End users aren't going to stand for it, or understand it. Soon, we'll have the UAC-Apple-type commercials from Adobe making fun of Silverlight and all the restarts it requires :)

    Remember, anything which makes an end user close their browser runs a huge risk of making them drop from your site. That's completely forgetting the annoyance factor :)


    Tuesday, July 31, 2007 11:03 AM
  • Should only have to restart your browser in the case that you are upgrading from old bits while running Silverlight content in IE, or you are running Firefox. In the future, the first scenario, upgrading, shouldn't be a problem, most users won't even run an installer again, but rather just take the automatic updates. The second problem is due to how Firefox caches available plugins at start up, and I don't see that going away in the near future.

     I'll note that when I try to install Flash from Firefox, it tells me to close my browser before I'm even allowed to install at all.

    Tuesday, July 31, 2007 11:24 AM
  • On my development machine it seems to work fine, but on client's machines it seems to not install correctly (RC not 1.1) until I re-install it several times.  Perhaps there are hidden IE windows somewhere (e.g. in Windows Messenger or something) that is causing problems.

     Anyone at MS have any good advice to make sure it works the first time?  Consumers are not likely to re-install.

    Tuesday, July 31, 2007 3:59 PM
  • Swildermuth, does this happen consistantly on their machine? For example, if they uninstall and then re-install will it fail on the first time and succeed several times later? If so, how many re-installs does it take? Is it the same number everytime?

     I think it's very unlikely that re-installing is actually fixing some issue that was broken on the first install. I think it's more likely that the page the client is viewing was updating between one of the installs or the client was downloading an old version of Silverlight, and it was updated between installs (this idea only works if they were re-downloading it everytime, which they should be).

    Tuesday, July 31, 2007 4:10 PM
  • I think it's very unlikely that re-installing is actually fixing some issue that was broken on the first install. I think it's more likely that the page the client is viewing was updating between one of the installs or the client was downloading an old version of Silverlight, and it was updated between installs (this idea only works if they were re-downloading it everytime, which they should be).

    I wouldn't discount Shawn's comments so quickly. I have the same problem on two different machines with both the Alpha and the Alpha refresh. Two installs on each machine and it works. Please see my other messages in this thread.


    Wednesday, August 01, 2007 12:25 AM
  • So this happens on your computer:

    1) uninstall silverlight

    2) install silverlight 1.1 Alpha refresh

    3) open browser

    4) navigate to some silverlight content

    5) it fails to load

    6) install silverlight 1.1 Alpha refresh again

    7) open browser again

    8) navigate to some silverlight content

    9) succeeds

    And it happens everytime you install? If that's the case then can you take a log of step 4 using Process Monitor ( ). The fact that content worked at all with the MIX Alpha suggests to me it's a breaking change with Silverlight.js that is coming up in a weird way. Also please include a link to whatever Silverlight content you use.

    Wednesday, August 01, 2007 12:33 AM
  • I did not uninstall the old version befing installing the new version of Silverlght. I wouldn't expect a user to do that.

    From the original Alpha install:

    1. Navigate to page that uses SL (using IE7)

    2. Get prompted to download SL

    3. Get error which turns out to mean that the browser needs to be restarted.

    4. Close all browser instances, and all other open apps.

    5. Open the browser and nav back to that page.

    6. Get prompted yet again to install SL

    7. Install SL again. No restart required this time.

    8. SL app works.

    From the refresh install:

    1. Change my example so it requires the 1.1 alpha refresh

    2. Navigate to that page

    3. Get prompted to install the alpha refresh as expected

    4. The rest is the same as the original install starting from step 3 on, except the error message is more verbose and actually says to restart your browser :)

    Trust me, I've been doing Silverlight 1.1 for a bit. It's not something silly like the breaking change :)

    Content used: For the original install, the Carbon Offset Calculator I and my teammate wrote (which is now in production, and will be updated to the 1.1 refresh as soon as the client approves the change - hopefully really soon!), as well as the Silverlight Balloons example I wrote. For the Alpha Refresh, my current Silverlight Balloons example.

    Verified on my PC, which has tons of dev stuff, and is Windows XP Pro, and my wife's laptop which has no dev stuff and is Windows XP Media Center edition. IE7 is the browser in both cases.


    Wednesday, August 01, 2007 12:57 AM
  • Just as a sanity check can you post the full URL that you get linked to when the installer gives you the error? Also if you could get the Process Monitor logs of when IE loads the Silverlight content and fails (when you would expect it to succeed). If you don't uninstall before you start these steps how do you know it works on the second time? Can you perform these steps again but do an uninstall at the beginning to help narrow down what is actually breaking here?
    Wednesday, August 01, 2007 1:18 AM
  • I just went through it in Vista (recording in the process monitor) and it all worked close to as expected, so that test was useless. In fact, the Vista install experience was quite different than xp.

    I don't have another XP machine or image hanging around, so I won't be able to go through the repro until the next release (if it happens at that time and isn't just pushed down)

    I'd like to say this is a non-issue since it works on Vista, but most folks haven't made that OS jump yet, and won't this year.


    Wednesday, August 01, 2007 10:25 AM