none
Multiple contracts in one WCF service_But error for calling the second contract "Multiple filters matched." RRS feed

  • Question

  • I have multiple contracts in one WCF:

     namespace SysLap.Services.Web.DataExtractor
    {
    
    [ServiceContract]
    public interface IServiceDataExtractor
        {      
        [OperationContract]
        [WebGet]
        List<User> GetAllUsers(/*CommonParams commonParams*/);
    
    [ServiceContract]
    public interface IScopesExtract
            {
                [OperationContract]
                [WebGet]
                List<SyScope> GetAllScopes();
            }
    }


    and the Web.config is well configured:

    <endpoint address="rest" behaviorConfiguration="restBehavior"
          binding="webHttpBinding" contract="SysLap.Services.Web.DataExtractor.IServiceDataExtractor" />
        <endpoint address="rest" behaviorConfiguration="restBehavior"
          binding="webHttpBinding"  contract="SysLap.Services.Web.DataExtractor.IScopesExtract" />
      </service>

    for the service GetAllUsers, it is worked very good, but for the service GetAllScopes, when i test it with SOAP UI, i get this error "Multiple filters matched" :

    <p class="heading1">Request Error</p>
    		<p>The server encountered an error processing the request. The exception message is 'Multiple filters matched.'.
    			See server logs for more details. The exception stack trace is: </p>
    		<p> at System.ServiceModel.Dispatcher.EndpointDispatcherTable.LookupInCache(Message message, Boolean&amp;
    			addressMatched)
    			at System.ServiceModel.Dispatcher.EndpointDispatcherTable.Lookup(Message message, Boolean&amp;
    			addressMatched)
    			at System.ServiceModel.Dispatcher.ChannelHandler.GetDatagramChannel(Message message, EndpointDispatcher&amp;
    			endpoint, Boolean&amp; addressMatched)
    			at System.ServiceModel.Dispatcher.ChannelHandler.EnsureChannelAndEndpoint(RequestContext request)
    			at System.ServiceModel.Dispatcher.ChannelHandler.TryRetrievingInstanceContextCore(RequestContext request)
    		</p>

    how can I fix it ? Thanks


    Thursday, October 3, 2019 2:48 PM