none
Cube processing suddenly failing with timeouts RRS feed

  • Question

  • We have a two cubes that previously had no issues being processed with the full option.

    Suddenly the cube is now failing with timeouts.

    I have narrowed it down to two particular measures, where it cannot even process a single partition on its own.

    With nothing else running on the server, both SQLServer and SSAS run on same server.

    If I attempt to process the above partition, activity monitor shows the query processes start up and almost immediately all of it goes to runnable, suspended with PageIOLatch_SH, CXPACKETS and SLEEPTASK. 

    No other activity, they all just sitting around waiting until it times out.

    On the server itself, there is no activity, idle cpu and memory to spare.

    I have checked the queries, the plan dont indicate any tempdb spills or missing indices.

    I have rebuilt all the indices including columnstores.

    Deleted the cube and redeployed.

    The same data and cube deployment on the test server is fine.

    We are running a virtual cluster of 2 servers.

    Any ideas on what else to try would be welcome.

    Thanks

    Jon

    Saturday, January 25, 2020 2:49 PM

All replies

  • Hi Jon,

    What are the shown error messages on the screen, could you share us the screenshot please?


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, January 27, 2020 8:11 AM
  • Its just a standard timeout error HY00 etc.

    I tracked it down to the query, it appears the larger partition queries seem to hang almost immediately

    Its not even attempting to run, just says waiting.

    Could it be some sort of IO issue, on a VM level?


    Thursday, January 30, 2020 8:19 AM