none
.Net Frameworks 3.5 Error code 1603 RRS feed

  • Question

  • This is my error log, please help me.


    [02/11/10,13:32:48] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/11/10,13:32:48] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/11/10,13:33:07] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/11/10,13:36:40] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/11/10,13:36:40] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/11/10,13:37:00] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/11/10,13:42:15] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/11/10,13:42:15] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/11/10,13:42:37] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/11/10,13:51:05] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/11/10,13:51:05] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/11/10,13:51:22] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/11/10,14:05:01] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/11/10,14:05:01] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/11/10,14:05:17] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/11/10,14:26:43] WIC Installer: [2] CGenericComponent::Install() expects the setup file for WIC Installer but fails to get it
    [02/11/10,14:26:43] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467259.
    [02/11/10,14:26:58] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    [02/11/10,14:38:56] WIC Installer: [2] Error code 1603 for this component means "Fatal error during installation.
    "
    [02/11/10,14:38:56] WIC Installer: [2] Setup Failed on component WIC Installer
    [02/11/10,14:39:13] WapUI: [2] DepCheck indicates WIC Installer is not installed.
    Thursday, February 11, 2010 7:42 PM

Answers

  • Sorry to hear you're having problems installing 3.5. We will need additional installation logs, however. Please download and run the log collection utility from http://go.microsoft.com/?LinkId=8967043. This creates the file %TEMP%\vslogs.cab. Post this to a server to be downloaded. If you need hosting space, consider using http://skydrive.live.com .

    Deployment Technology Group, Microsoft http://blogs.msdn.com/heaths
    • Marked as answer by YiChun Chen Friday, February 19, 2010 3:51 AM
    Thursday, February 11, 2010 10:16 PM
  • Hi Ansem,

    Some clarification with you:
    What's your OS?

    For error code "1603", it's a common error message which means "fatal error during installation".

    As Heath mentioned, we need to look into the log files for further troubleshooting:

    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Download .NET Framework 3.5 full package and install .NET Framework 3.5
      (For Vista or later OS, the installer must be run with administrator privileges - Right-click the installer >> "Run as Administrator")
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, February 19, 2010 3:51 AM
    Saturday, February 13, 2010 6:45 AM

All replies

  • Sorry to hear you're having problems installing 3.5. We will need additional installation logs, however. Please download and run the log collection utility from http://go.microsoft.com/?LinkId=8967043. This creates the file %TEMP%\vslogs.cab. Post this to a server to be downloaded. If you need hosting space, consider using http://skydrive.live.com .

    Deployment Technology Group, Microsoft http://blogs.msdn.com/heaths
    • Marked as answer by YiChun Chen Friday, February 19, 2010 3:51 AM
    Thursday, February 11, 2010 10:16 PM
  • Hi Ansem,

    Some clarification with you:
    What's your OS?

    For error code "1603", it's a common error message which means "fatal error during installation".

    As Heath mentioned, we need to look into the log files for further troubleshooting:

    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Download .NET Framework 3.5 full package and install .NET Framework 3.5
      (For Vista or later OS, the installer must be run with administrator privileges - Right-click the installer >> "Run as Administrator")
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, February 19, 2010 3:51 AM
    Saturday, February 13, 2010 6:45 AM