none
Many errors in SQL Server 2014 RRS feed

  • Question

  • I, unfortunately, am new with SQL Servers, however I have used SQL Server 2012 R2 before with minimal problems which I corrected at the time. 

    I recently installed SQL Server 2014, but have been having problems right from the start.  First, during installation it fails to install Database Engine Services, and SQL Server Replication.  I have tried named instances and default, but nothing there works.  Then when I try to connect, no matter how I connect, it fails there also.  The paths to certain files are trying to go to E: which is my CD Rom drive.  Also, and I know with these paths incorrect, nothing will start, from the browser to the server.  Why is it trying to install the .mdf files to a directory that doesn't exist?

    I am unable to post screenshots of the log and errors, as I am posting this from another computer and not the server.

    Running Microsoft Server 2012 R2 with SQL Server 2014 and SQL Server Configuration Manager 2014

    Tuesday, November 24, 2015 3:38 AM

Answers

All replies

  • Hi TerryN78,

    According to your description, you fail to install SQL Server 2014. For further analysis, please help to post the SQL Server summary.txt and detail.txt log files. The log files can be found in %Program files%\Microsoft SQL Server\120\Setup Bootstrap\Log. And you can upload  the summart.txt and details.txt files on onedrive.

    Besides, please also post the full error message that you get when connecting to SQL Server 2014.

    Thanks,
    Lydia Zhang


    Lydia Zhang
    TechNet Community Support



    Tuesday, November 24, 2015 6:08 AM
    Moderator
  • I found the summary.txt, but not the detail.txt log file, however I did find the errorlog. 

    <iframe frameborder="0" height="120" scrolling="no" src="https://onedrive.live.com/embed?cid=93A878FFF5D5F99A&resid=93A878FFF5D5F99A%21464&authkey=ALMo8lLyK06mK-s" width="98"></iframe><iframe frameborder="0" height="120" scrolling="no" src="https://onedrive.live.com/embed?cid=93A878FFF5D5F99A&resid=93A878FFF5D5F99A%21463&authkey=ANpsAtCNvrBU6YY" width="98"></iframe><iframe frameborder="0" height="73" scrolling="no" src="https://onedrive.live.com/embed?cid=93A878FFF5D5F99A&resid=93A878FFF5D5F99A%21465&authkey=AL1n_1Wz8RlHpaQ" width="320"></iframe>

    Here is everything I can think of to post.  According to the first part of the errorlog, it shows it installed to the correct path, but later on in the same log, it shows a different path.  I'm confused.

    Wednesday, November 25, 2015 12:31 AM
  • Hi TerryN78,

    Please follow the steps in below blog to change the paths of those 3 databases(MSDB, model ,tempdb) to the right location. Then check if you can connect to SQL Server 2014 Express successfully.

    http://social.technet.microsoft.com/wiki/contents/articles/31786.sql-server-not-starting-after-fresh-installation.aspx

    Thanks,
    Lydia Zhang

    Lydia Zhang
    TechNet Community Support


    Wednesday, November 25, 2015 6:19 AM
    Moderator