none
Visual Studio 2017 15.6 Crashes when starting up RRS feed

  • Question

  • Hi All.

    Can anyone tell me why Visual Studio 2017 will not start/keeps crashing on start up? I installed Visual Studio 2017 15.6

    OS: Windows 10 1709. 

    VS apps installed in IDE: ReSharper (2017.3.5), ProductivityPowerTools 2017, ColorThemeEditor 2017

    Installation is successful, then when I restart and try to open Visual Studio, it crashes.

    Here is the error from EventViewer:

    Log Name:      Application
    Source:        Application Error
    Date:          4/23/2018 12:46:03 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      WIN-UUY2KHXYXT.corp.avanade.org
    Description:
    Faulting application name: devenv.exe, version: 15.6.27428.2037, time stamp: 0x5acc01e3
    Faulting module name: KERNELBASE.dll, version: 10.0.16299.371, time stamp: 0xee297154
    Exception code: 0xc000041d
    Fault offset: 0x00103ef2
    Faulting process id: 0x4340
    Faulting application start time: 0x01d3db3bb0999c86
    Faulting application path: C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\devenv.exe
    Faulting module path: C:\windows\System32\KERNELBASE.dll
    Report Id: b0a641f1-3403-49f9-a2b9-37b7e1de937f
    Faulting package full name: 
    Faulting package-relative application ID: 
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2018-04-23T19:46:03.451512700Z" />
        <EventRecordID>59396</EventRecordID>
        <Channel>Application</Channel>
        <Computer>WIN-UUY2KHXYXT.corp.avanade.org</Computer>
        <Security />
      </System>
      <EventData>
        <Data>devenv.exe</Data>
        <Data>15.6.27428.2037</Data>
        <Data>5acc01e3</Data>
        <Data>KERNELBASE.dll</Data>
        <Data>10.0.16299.371</Data>
        <Data>ee297154</Data>
        <Data>c000041d</Data>
        <Data>00103ef2</Data>
        <Data>4340</Data>
        <Data>01d3db3bb0999c86</Data>
        <Data>C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\Common7\IDE\devenv.exe</Data>
        <Data>C:\windows\System32\KERNELBASE.dll</Data>
        <Data>b0a641f1-3403-49f9-a2b9-37b7e1de937f</Data>
        <Data>
        </Data>
        <Data>
        </Data>
      </EventData>
    </Event>

    Monday, April 23, 2018 7:54 PM

Answers

All replies

  • Hi zFischer,

    Welcome to the MSDN forum.

    Does this issue happen after your initial VS 2017 installation? Now the latest version is 15.6.6 and upgrade to the latest one.

    There are some reasons that may be cause the crash, please have a try with the following to troubleshoot this issue:

    1. Run VS as administrator
    2. Delete this folder: %LocalAppData%\Microsoft\VisualStudio\15.0_xxx\ ComponentModelCache
    3. Open CMD and navigate to the VS 2017 installation folder like C:\Program Files (x86)\Microsoft Visual Studio\2017\xxx\Common7\IDE and run the command: devenv /safemode to run it as safe mode, then check if the installed extensions caused this issue.
    4. Re-run the VS installer as administrator and More-Repair to repair it
    5. perform a clean boot in Windowsand start VS 2017

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, April 24, 2018 6:21 AM
    Moderator
  • Interestingly, the issue goes away when I uninstalled Stardock WindowBlinds. It must be messing with something used bu VS.
    Thursday, April 26, 2018 3:51 PM
  • Hi zFischer,

    I'm so glad to hear that your issue is solved and thank you for your sharing.

    Please mark your reply as the answer and that will help other community members who meet the similar issue to easier search this helpful information, then we can close this thread for you, thanks.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, April 27, 2018 1:21 AM
    Moderator
  • I have the Community Edition of VS installed (v15.7.2) and Window Blinds and I also had the problem with VS crashing on startup. Simply excluding devenv.exe from Window Blinds did not fix it and I had to revert my theme back to the Default Windows theme and unload Windows Blinds before VS would then start normally. Given that VS used to run perfectly well with WB I would argue that VS is now doing something that has broken WB rather than the other way around. Anyway, problem solved.
    Tuesday, May 29, 2018 6:29 AM