none
Cannot save password for new login created RRS feed

  • Question

  • I'm using SQLExpress with Mgmt Studio V18.3.1.  When I create a new login (right click on Security/Logins folder, New Login...), I choose SQL Server Authentication, then supply the Login name and password, as well as the default DB, then hit OK to save.  I can't log in with this, and when I log in the normal way (Windows authentication) and then find the new login (again going to Security/Logins)and look at its properties, I see that the password is different (I can't see what it is, but it's longer, 15 characters long).

    I've repeated this several times with new logins, and each time it shows a password that is 15 characters long, which I did not do.

    Is this a limitation?  Its as if it asks for a password but then ignores it and uses some other probably pre-existing password.  What gives?

    Thursday, January 16, 2020 6:07 AM

All replies

  • Is the below option enabled? Right click on Server name and go to properties. 

    After enabling, try to login with new user credentials


    If the response helped, do "Mark as answer" and upvote it
    - Vaibhav

    Thursday, January 16, 2020 6:30 AM
  • As Vaibhav, using SQL login requires that the SQL Server is running in "mixed Auth mode" = Windows + SQL Login; changing the setting requires a restart of SQL Server service.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Thursday, January 16, 2020 6:45 AM
  • Hi friend,

    The password is displayed with a length of 15 characters, this is only the default display (all SQL Server logins display their passwords this way).

    It does not represent the length of your password. This is a protection mechanism. Meanwhile if you try to copy the password and you will find it prompts "Not Allowed ...".

    your real problem should be that SQL Server and Windows Authentication mode(mixed Auth mode) is not turned on.

    Best regards,

    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 16, 2020 8:02 AM
  • Hi EricShell,

    If you have resolved your issue, please mark the useful reply as answer. This can be beneficial to other community members reading the thread.

    In addition, if you have another questions, please feel free to ask.

    Thanks for your contribution.

    Best regards,
    Cris


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 17, 2020 5:43 AM
  • Hi Vaibhav,

    Sorry for not getting back earlier, I thought I would be notified by email for responses but I wasn't!

    So I was NOT in mixed mode - the choice selected that I see from the server properties was Windows Authentication.  But I still have the same problem after following the recommendations. 

    So I went to change it to the mixed mode, then restarted. 

    Then I created a new account after right clicking the Security/Logins, and then I chose SQL Server authentication when creating the new login (there was no combined option, it was either Windows Authentication, or SQL Server authentication, or mapped to certificate or asymmetric key). 

    Then I disconnected, tried to log in using the new login with SQL Server authentication (again, no mixed mode option to log in, just SQL Server mode or Windows authentication mode or Azure options).  And this failed.  Same thing happened after restarting.


    Wednesday, January 22, 2020 11:09 PM
  • Thanks Cris, that's helpful and good to know.
    Wednesday, January 22, 2020 11:11 PM