locked
Explore FileTable Directory is disabled: RRS feed

  • Question

  • Hi,

    I've created a filetable in SQL Server 2012. When I right click on the name of the file table in object explorer in SSMS, the option "Explore FileTable Directory" is disabled. Could you please let me know what is the way to enable this option?

     

    My basic idea for trying out this is, to locate the path of the file table. If there is any other way to find the path of the file table let me know.

    Thanks,

    Santosh

     

     

    Tuesday, January 17, 2012 8:21 AM

Answers

  • Hi,  I can't see your image for your post, but you can enable this by using by either the below:

     

    alter database dbname

    set filestream(NON_TRANSACTED_ACCESS=FULL, DIRECTORY_NAME='filetabledirectory')

     

    or even easier

    On the database options page set the 'FILESTREAM Non-Transaction Access' to the required access level.

    Tuesday, January 17, 2012 8:11 PM

All replies

  • For getting the path of the file table you can use File stream / file table functions too

    http://technet.microsoft.com/en-us/library/gg492141(SQL.110).aspx

     

    Tuesday, January 17, 2012 8:30 AM
  • Thanks Sorna.

    I'm able to get the path of the filetable with the file table functions. But not able to navigate to these folders. It says 'You do not have permissions...'. (Although I'm accessing in my local machine and I've Administrator rights) So trying to enable the "Explore FileTable Directory" option.

    Tuesday, January 17, 2012 9:25 AM
  • Hi,  I can't see your image for your post, but you can enable this by using by either the below:

     

    alter database dbname

    set filestream(NON_TRANSACTED_ACCESS=FULL, DIRECTORY_NAME='filetabledirectory')

     

    or even easier

    On the database options page set the 'FILESTREAM Non-Transaction Access' to the required access level.

    Tuesday, January 17, 2012 8:11 PM
  • Try starting SSMS by right-clicking it and select "Run as Administrator".


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Tuesday, January 17, 2012 10:22 PM
  • Thanks Kevin. "Explore FileTable Directory" option is enabled.

    But I'm getting the error message "The File location cannot be opened. Either access is not enabled or you do not have permissions for the same." when I choose the option "Explore FileTable Directory". Is there any other setting need to be done or given permission to access the folder?

    Thanks,

    Santosh

     

     

     

     

    Wednesday, January 18, 2012 3:28 AM
  • Thanks. Now Explore FileTable Directory" option is enabled.
    Wednesday, January 18, 2012 10:03 AM