none
Silverlight plugin keeps asking for install when running from local site.

    Question

  • Silverlight plugin keeps asking for install when running from local site. (http://xxxx, where xxxx maps to localhost).

    This happens in Chrome, Firefox (this one won't even show the image). I didn't check IE9, because I cant log on to the site, using IE9...
    The version Silverlight installed is 5.1.10411.0.

    It used to work, but since yesterday not anymore; this takes way too much time to solve... any help is welcome. Silverlight works fine on other sites (www).

     

    Tuesday, June 19, 2012 10:20 AM

Answers

  • Couldn't find a solution, uninstalled and reinstalled all development software (VS2010, SP1, tools, sdk's). After that, it worked again.

    Sunday, June 24, 2012 2:45 PM

All replies

  • Uninstall silverlight and reinstall again. That will fix this issue.

     

    Thanks,

    Kumar

     

     

    Tuesday, June 19, 2012 1:48 PM
  • Hi StackTrace,

    Do you have the issue resolved?

    Since I cannot reproduce your issue locally. I will suggest that delete all the temporary files(including these cached files used by IE and Firefox(or Chrome) ). Then, try the tool to manually clean up a broken Silverlight installation:

    http://blogs.msdn.com/b/rpomeroy/archive/2008/06/10/how-to-manually-clean-up-a-bad-silverlight-installation.aspx#comments 

    Best Regards,

    Tuesday, June 19, 2012 10:34 PM
    Moderator
  • I haven't resolved the issue yet; I tried the delete cache & fixit solution, without success. 

    When the local page asks to install the plugin, the downloaded file won't install (unable to).
    Other www sites with silverlight controls work correclty.

    Tonight (8 hours from now), I'll deinstall and reinstall  silverlight (again) in the hope to fix this. I can'develop SL anymore right now :(

    Wednesday, June 20, 2012 4:12 AM
  • You can find download link for SL5 here.( 32bit or 64bit)

    http://www.silverlight.net/downloads

    Wednesday, June 20, 2012 4:59 AM
  • I cannot uninstall silverlight :(  error code 2753

    When I run MicrosoftFixit50747 silverlight is not in the list of installed programs anymore....

    Websites with silverlight still run without asking me to install silverlight  (!)

    The local website still does ask to install Silverlight, but it does not succeed and the message is "version already installed" ....

     

    Wednesday, June 20, 2012 10:05 AM
  • Current status is: 

    - all silverlight sites ask for plugin install

    - install fails - "same version already installed"

    - Get Microsoft Silverlight site sys Silverlight 5.x is installed  

    - silverlight 5.x is listed in installed programs, but uninstalling it results in the error code 2753

    - renaming the silverlight folder on the file system has no effect at all

    What else can I do?

    Wednesday, June 20, 2012 2:38 PM
  • Hi,

    As you can access other Silverlight applications it seems is not Silverlight runtime or your browser issue. Most likely the page itself has some problems. What's the HTML of the pages? Does it work if you create a new Silverlight project? Could you use fiddler to check the request/response to localhost(use ip4.fiddler instead of localhost to get trace data)?

    http://www.fiddler2.com/fiddler2/

    Please post Fiddler trace here for further discussion.

    Thursday, June 21, 2012 5:56 AM
  • Hi, thanks for your response.

     I have VS2010 on this system, but removed everything that sounds like Silverlight (tools, sdk's etc.).  Still. I can't uninstall /reinstall silverlight, no silvelright site will run.... 
    I started a new thread for this problem, as it is not only local sites anymore: "http://forums.silverlight.net/t/257534.aspx/1?Silverlight+installation+corrupted+urgent.

    I need a way to clean the system and reinstall Silverlight... MS Fixit etc didn't work out either...


     

    Thursday, June 21, 2012 6:24 AM
  • Hi StackTrace,

    Are you using Internet Explorer?

    Please check if you are using Internet Exploeer 9 64-bit. If this is the case, IE 9 64-bit only support silverlight 5 64-bit, so please download and install it from below link

    http://go.microsoft.com/fwlink/?LinkId=229321 (for windows 64-bit)

    If above steps doesn't solve this issue, please provide more information of your system os and browser version.

     

    Best Regards,

    Friday, June 22, 2012 4:04 AM
  • Hi, thanks for your reply.

    The problem exists in all my browsers, Chrome, Firefox. I don't use the 64bits version of IE.
    Installing the 64bits SL also fails (Message ID:  1603) (A fatal error occurred during installation)
    32bits: MessageId  1514 (already installed).

    It HAS worked, before the corruption occured. Can't develop Silverlight for days now, on this machine. (nor run Silverlight on www sites)
    OS: Window 7  Enterprise 64bits; 16Gb Ram, Intel i7 2670QM

    Friday, June 22, 2012 5:24 AM
  • Couldn't find a solution, uninstalled and reinstalled all development software (VS2010, SP1, tools, sdk's). After that, it worked again.

    Sunday, June 24, 2012 2:45 PM
  • I too having the same problem in my 32bit system as i cleared all the cache and unistall the silverlight but it asked me again again to install the silverlight plugin.

    Saturday, September 29, 2012 7:01 AM
  • No, it does not.
    Thursday, March 16, 2017 1:51 PM