none
How Can I use TLS 1.2 in .Net framework 4.0

    Question

  • Net framework 4.0 don't support TLS 1.2, but My ap is 4.0, and now I must use TLS 1.2, is there some ideas to implement is ?

    Thanks

    Friday, December 26, 2014 7:08 AM

Answers

All replies

  • Hi,

    .NET Framework 4.0 does not have the TLS 1.2 or TLS 1.1. To use TLS 1.2, you must use .NET Framework 4.5.

    For this scenario, you may try to upgrade the .NET Framework from version 4.0 to version 4.5.

    For more information, you could refer to:

    http://blogs.msdn.com/b/benjaminperkins/archive/2014/11/04/using-tls-1-2-with-wcf.aspx

    https://octopusdeploy.com/blog/poodle

    Regards

    Monday, December 29, 2014 2:12 AM
    Moderator
  • If your app is .NET 4.0, you can still use TLS 1.2 by installing .NET 4.5 on your server.  Your app will not have to be upgraded and the upgrade from 4.0 -> 4.5 is an "in-place" upgrade and went amazingly smoothly for me.

    Thursday, September 22, 2016 9:49 PM
  • If your app is .NET 4.0, you can still use TLS 1.2 by installing .NET 4.5 on your server.  Your app will not have to be upgraded and the upgrade from 4.0 -> 4.5 is an "in-place" upgrade and went amazingly smoothly for me.

    Hi Jacqueline, I'm using .NET 2.0 for my website. How could I get it work for TLS 1.2?

    Any hints shall be greatly appreciated.

    Thank you very much!

    Tony

    Thursday, June 1, 2017 4:49 PM