Netflix error: 2104


  • Hi 

    After I installed the new Silverlight 5 I've had problems with Netfilx. When trying to watch a movie it tells me that there's an error 2104 and that I have to uninstall and re-install Silverlight. I did exactly as told, several times, but without any luck. I contacted Netflix and they tried to help me but in the end they told me I had to contact Silverlight. So here I am. What should I do about it?

    Thank you guys for your help.

    Sunday, January 19, 2014 10:46 AM


All replies

  • Same problem here and I am unable to figure out why I cant fix this.

    Sunday, January 19, 2014 6:52 PM
  • Same problem, started after upgrading to windows 8.1, and can not even uninstall Silverlight. I get an installer error 2503
    Monday, January 20, 2014 12:21 AM
  • Hi ChristofferSp,

    You may try cleaning the corrupted Silverlight installation and then reinstalling Silverlight according to the link below:

    How to clean a corrupted Silverlight installation and then reinstall Silverlight.

    In addition, you may refer to the similar questions below:

    netflix error code 2104

    ErrorCode: 2104 On Netflix

    If you need further assistance, please let me know.

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, January 20, 2014 2:31 AM
  • Hi,

    I've been having the same problem as the opening poster. I have tried reinstalling Silverlight, with no success. I tried the corruption fix, and that didn't work. I've tried all methods mentioned on here and it still won't work. I have tried removing all files of Silverlight before installation, again no success.

    It worked fine yesterday, but today it's completely stopped.

    Further info:

    I'm using Windows 7 and Google Chrome to view Netflix.

    Please help,


    Sunday, February 02, 2014 8:06 PM
  • Hi, had same problem all weekend. Have just installed Firefox, and everything working again. Hope this helps you.
    Monday, February 03, 2014 7:06 PM
  • I've been working on this stuff for hours. I re-installed everything and ended up just deleting myentire browser history/cache/cookies/download history.
    This has actually worked for me after even going through my registry. Just try reinstalling chrome or whatever your browser is and then clear your browsing data.

    I hope this helped.

    • Proposed as answer by ollie89 Wednesday, February 05, 2014 9:27 PM
    Wednesday, February 05, 2014 3:37 AM
  • This fixed the problem for me - uninstalled silverlight restarted etc. to no avail

    Simply clearing cookies and cache fixed the problem.  Thanks so much!
    Wednesday, February 05, 2014 9:28 PM
  • This actually worked... thank you
    Wednesday, February 12, 2014 10:51 PM
  • This worked for me, thank you so much. I have spent hours since yesterday where I got the error message initially and tried to sort this by un-intstalling and re-installing (numerous times!). Clearing everything has solved it! Amen :)
    Thursday, February 13, 2014 2:10 PM
  • I'd just like to say this worked for me too.  I emptied my Chrome cookies and cache from "the beginning of time" (that's actually what the option is called!) and streaming went back to normal.  Thanks all for your input.
    Sunday, February 16, 2014 10:33 PM