none
Require users to edit in MS Word on Desktop NOT in Browser RRS feed

  • Question

  • Is there a way in SharePoint for the administrator to require that users edit the document in Word and not in their browser?

    Any help would be greatly appreciated. Thanks!

     
    Friday, December 6, 2019 6:20 PM

All replies

  • Hi SharePointUser357.

    You can do that at the site collection level by activating the "Open Documents in Client Applications by Default" site collection feature.
    You can also set it at the document library level, by going to the document library settings page, clicking Advanced settings and choosing the "Open in the client application" option in the "Opening Documents in the Browser" section.

    Bye.


    Luigi Bruno
    MCP, MOS, MTA, MCTS, MCSA, MCSE

    Friday, December 6, 2019 9:43 PM
  • Hi SharePointUser357,

    Any progress on your troubleshooting?

    If you want to use this feature at the site collection level, you can refer to the method mentioned by Luigi.

    If you only want to use this feature in a single library, you can change it in the library settings.

    Library settings - Advanced Settings

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Proposed as answer by Michael Han6 Tuesday, December 10, 2019 9:25 AM
    Monday, December 9, 2019 2:22 AM
  • Thanks so much for this Luigi and Itch. I've been able to get this working at the individual library level, but can't seem to get it to work for our entire SharePoint site. How do I make the change at the site collection level?
    Tuesday, December 10, 2019 11:39 PM
  • Hi SharePointUser357,,

    As far as I know, according to my tests, when you enable the "Open in the client application" feature, the entire site collection will take effect.

    If you still open in your browser by default after you enable it, it is recommended that you reset it once using the powershell command.

    In addition, it not only works throughout the site collection, but also can be set up throughout the farm.

    More information:

    https://docs.microsoft.com/en-us/webappsserver/set-the-default-open-behavior-for-browser-enabled-documents-office-web-apps-when-used-with-sharepoint-2013

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, December 11, 2019 1:41 AM
  • Thanks so much for this Luigi and Itch. I've been able to get this working at the individual library level, but can't seem to get it to work for our entire SharePoint site. How do I make the change at the site collection level?

    You can do that at the site collection level by activating the "Open Documents in Client Applications by Default" site collection feature.

    Bye.


    Luigi Bruno
    MCP, MOS, MTA, MCTS, MCSA, MCSE

    Wednesday, December 11, 2019 8:50 AM
  • Hi ,

    If you think the replies are helpful to you, please remember to mark them as answers. It will help others who meet the similar question in this forum.

    Thank you for your understanding.

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, December 17, 2019 7:59 AM