Install Problem: Silverlight and Mac OSX


  •  I recently installed Silverlight 3.0 for mac osx snow lepard. I understood it was having problems so i uninstalled it. Now i wont to re install it, i am given the messege:

    "Microsoft Silverlight Browser Plug-In can't be installed on this disk. A newer version of this software already exists on this disk"

     I know for a fact there is no version of silverlight on my mac and now i cannot install silverlight!

     Any help?


    Sunday, February 07, 2010 10:44 PM

All replies

  •  Hi all!

    On Mac i have the same problem with 10.5.8 version, not snow leopard

     Thanks for help


    Monday, February 08, 2010 12:45 AM
  • You need to make sure you have cleaned up the receipts.

    Tiger/Leopard : /Library/Receipts

    SnowLeopard : /var/db/receipts
    Tuesday, March 02, 2010 1:34 PM
  • I too am having the same exact problem. I've deleted every occurrence I can find. Still getting the error that a newer version exists. Please help.

    Tuesday, January 18, 2011 10:58 AM
  • I cannot get this to work either. Deleted everything I can find. 

    Still getting "a newer version exists." 

    Tuesday, January 18, 2011 10:58 AM
  • Same problem can anyone answer this?

    Monday, July 04, 2011 2:24 AM
  • Same problem here, expect that I stupidly installed Silverlight 5 beta on Mac OSX 10.6.8 and now I cannot reinstall Silverlight 4, even after deleting every trace of Silverlight that I can find. I've tried to follow any and all instructions I can find to uninstall, to no avail. Is  Silverlight meant to sabotage Macs and/or Netflix? Is there any genuine, official support available for Mac Silverlight? No one seems to notice or care about this thread except other unhappy Mac users.

    Saturday, July 09, 2011 12:51 AM
  • Update to my post above--

    I still have NOT managed to reinstall Silverlight 4, but I have managed to get Silverlight 5 to work on the Mac. I reinstalled Silverlight 5 and then ran the Silverlight Debugging again. This time it worked, or maybe I just configured it correctly, because I WAS eventually able to stream Netflix. However, when I first restarted Firefox and tried to 'watch instantly', Firefox indicated I had to restart Firefox in 32-bit mode. After restarting Firefox, Netflix 'watch instantly' seems to work OK, so far.

    Saturday, July 09, 2011 3:02 AM
  • Further followup: I've discovered that Silverlight 5 beta is NOT 64-bit, that feature is in the future, so I guess Firefox has a right to complain. However, I don't understand how Safari can run in 64-bit and stream Netflix without complaining but Firefox can't. In any case, one must set the Mac Firefox 5 to run in 32-bit mode to stream Neflix, at least until the final release of a 64-bit Silverlight 5, maybe "by the end of 2011".

    Saturday, July 09, 2011 3:03 AM
  • i followed someone else's advice (kinda) and found all the silverlight files in "INVISIBLE FILES".

    In the Finder, choose File > Find or press Command (⌘)-F.
    From the far-left pop-up menu (labeled “Kind”), choose Other.
    In the list of search attributes, select the “File invisible” checkbox, and then click OK.
    In the related menu, choose Invisible Items.

    once loaded go to folder Private

    then to folder VAR

    then folder db

    theb folder Receipts

    scroll to any item and delete. there are a bunch of them.

    close, restart and install silverlight.

    Sunday, August 12, 2012 12:05 PM
  • On Mountain Lion 10.8, and presumably Lion 10.7 as well, the full path is /private/var/db/receipts - all the directory names are lower-case. Also, make sure you have Administrator priviliges or you won't be able to delete the*silverlight* files. I'm not sure if it was necessary,  but I deleted /Library/Internet Plugins/Silverlight.plugin and /Library/Application Support/Microsoft/Silverlight/ just to make sure.

    Many thanks for the tip, perryrants!


    Friday, August 31, 2012 4:10 PM