Phone 8 SDK broken - certificate expiration problem?


  • Hi there,

    Is anybody else running into issues installing the Phone 8 SDK fresh against VS 2012 currently? I am installing on a fresh installation of Windows 8.1 Enterprise 64bit with Visual Studio Ultimate 2012 (all updates installed).

    It fails to retrieve packages at some point into the installation:

    Retrying doesn't help. I tried running this on two different last mile networks to exclude issues with proxies etc.

    When aborting the installation, there might be a hint regarding the root cause:

    It seems like the files are downloaded via HTTPS and one of the download server certificates is expired or faulty.

    If you run into this, let's hope this gets fixed fast or someone at MS can provide an alternative download link that downloads an ISO instead having a web installer download package by package.

    EDIT: my guess about server certificates being invalid was wrong. Downloading the ISO image of the SDK and running the installation from there, also results in the same error. The certificates must relate to something that is used to sign the packages.

    I suspect there is something broken with the combination of Windows 8.1, VS 2012 and Phone SDK 8. Hope it gets fixed soon.


    Tobias W.

    • Edited by polarapfel Tuesday, October 08, 2013 12:16 PM more specific
    Monday, October 07, 2013 11:25 PM

All replies

  • I'm having the same issue here while installing Visual Studio Express for Windows Phone.
    Tuesday, October 08, 2013 4:35 AM
  • Taking a look further into this reveals that the certificate used to sign the msi has expired on October 6, 2013!! Microsoft needs to repackage the SDK with a newly generated certificate and make the SDK available for download.


    This shouldn't happen.

    EDIT: I found a workaround. Set your date before 10/6/2013 to get the SDK to fully install. Works for me. :)

    • Proposed as answer by mister2d Tuesday, October 08, 2013 5:46 AM
    • Edited by mister2d Tuesday, October 08, 2013 5:47 AM Adding resolution
    Tuesday, October 08, 2013 5:32 AM
  • Thanks for the solution, however does it mean we have to continue having the date set to this date to keep using the SDK?
    Tuesday, October 08, 2013 7:02 AM
  • Hi, Thanks a lot... The same problem happen for me. Now it working fine

    thanks once again...

    Tuesday, October 08, 2013 9:19 AM
  • Thanks. I guess the download packages must be maintained and updated. I also noticed, that the download package for the SDK from the Phone Developer Center web page is different from the one distributed via the MSDN download pages. Neither works on Windows 8.1 with VS2012, but both give different errors.

    Tuesday, October 08, 2013 12:10 PM
  • Thanks you, mister2d.

    Rodrigo Vega Heredia

    Thursday, October 10, 2013 7:28 PM
  • Another solution is:

    1.Install WPSDK 8.0 (It fails)

    2.Uninstall from Add and remove program  (or Install WPSDK 8.0 (it ask for repair/Uninstall)) --> Uninstall It from here

    3.Install Win8SharedSDKTools.msi ( iso\Packages\Windows_SDK\Win8SharedSDKTools.msi)
    4.Install WPSDK 8.0

    Best, nZeus

    Friday, October 11, 2013 10:54 PM