locked
The package execution failed. The step failed. RRS feed

  • Question

  • when i right click and execute the package from the Management Studio, it runs fine, everytime.  When i schedule a job to execute it, it fails, everytime.

    "The package execution failed.  The step failed."

    i have made sure that the package and job ran using credentials with more than enough access to everything.  Still, with no luck.  PLEASE!  I am at my wits ends here, and the boss is getting antsey...

    Any and all help is greatly appreciated...

    Anthony

    Thursday, February 2, 2006 10:08 PM

Answers

  •  odrc wrote:
    I am having the same problem. My package always runs when I am logged in but randomly fails when it is scheduled. Anyone have a resolution? Why would it work sometimes but not others?

    Randomly?

    That is odd. I would recommnd you to enable package logging and if you are using SQL Server Agent to schedule it; make sure you run it as CmdExec step type. That should give some clues about what cause of the problem

    Take a look a this:

     

    http://support.microsoft.com/kb/918760

     

    Friday, February 23, 2007 1:19 PM

All replies

  • Same problem here, feels like a permissions issue to me...

    Mine is running under a domain SQLServer account we've used for years.

    What do i need to do to run this job under this user?

    Thursday, February 2, 2006 10:56 PM
  • I've had the same problem, but it's running now...

    First I configured a package pwd. The location of the pkg is filesystem.
    When I add a new step to a job I had to change to the "Command line" Tab of the
    step configuration window. Then I was prompted for the password.

    Keep in mind that every time you conigure or re-configure a step which refers to a package
    with a pwd you must re-enter your pwd, e.g. when you configure the "On success action".

    The next obstacle is the schedule. I would rather configure the schedules with the "Manage Schedules" item of the Jobs context menu than setting it in the job configuration, because
    you can create more than one schedule with the same name and you don't see that in the
    Job config!!!
    You sometimes have to do Schedule configuration twice because the hole thing seems a bit buggy
    when associating schedules to jobs and simultaneously changing the schedule.

    Hope that helps.
    Fridtjof

    Friday, February 3, 2006 8:56 AM
  • my problem seems to be related.  I can create and run the package in Management Studio as a SSIS package saved in MSBD.  The package runs fine by itself but will not run in a job step and all I get is that the step failed.  The step just imports data from a text file.  The text file is on another server but is mapped correctly through explorer on the SQL server.  Package was created and job was created using the Administrator account.

    I've been trying to solve this for about a month now.

    Friday, February 3, 2006 9:05 PM
  • I think we have solved the problem.  There were two issues -

    1.  We were using the 'encript ...'  option, changed it to 'rely on server . . .'.

    2.  We were reading flat text files from another server.  We had set the path as drive-specific; ie  X:\ImportFiles\FileName.  We created new import packages using the drive reference as \\HostServerName\Directory\FileName.  The packages have been scheduled in Sql Agent jobs and are running fine. 

    Friday, February 17, 2006 3:02 PM
  • I'm having the exact same problem.  I tried the solutions suggested here, with no luck.  It sounds like some of you are still having the problem as well.  Has anyone found a solution for this??  Is this a bug?  Why would it work when ran manually, but not when scheduled?
    Tuesday, April 18, 2006 4:43 PM
  • We had trouble with the 64-bit version of SQLServer 2005 which won't connect to Excel or Access.  You can bodge round it by calling the 32-bit Dtexec.exe as a CmdExec job, details here: http://wiki.sqlis.com/default.aspx/SQLISWiki/x64.html
    Monday, October 2, 2006 3:14 PM
  • I am having the same problem. My package always runs when I am logged in but randomly fails when it is scheduled. Anyone have a resolution? Why would it work sometimes but not others?
    Friday, February 23, 2007 12:47 PM
  •  odrc wrote:
    I am having the same problem. My package always runs when I am logged in but randomly fails when it is scheduled. Anyone have a resolution? Why would it work sometimes but not others?

    Randomly?

    That is odd. I would recommnd you to enable package logging and if you are using SQL Server Agent to schedule it; make sure you run it as CmdExec step type. That should give some clues about what cause of the problem

    Take a look a this:

     

    http://support.microsoft.com/kb/918760

     

    Friday, February 23, 2007 1:19 PM
  • I spent an afternoon spinning my wheels on this problem.  My package ran fine while I was in Visual Studio, ran fine when I pointed to it under MSDB and chose "run package", but bombed consistently when I tried to run it from a job. The only message I got was "package execution failed."  This was an upload from Excel. 

     

    What I was doing wrong:  in creating the Excel Connection Manager, I used the option to browse to the source Excel file.  This resulted in a relative link, like S:\DW\Ratrix.xls.  When I changed this to a UNC link, like \\jsadmin1\shared\DW\ratrix.xls,  the package executed fine as a job.  

    Thursday, September 27, 2007 3:22 PM


  • If you use a step type of 'CmdExec' instead of 'Integration Services package' one; you will see a more descriptive error. This is also explained in the KB article that is in my previous post
    Thursday, September 27, 2007 3:34 PM
  • Thanks Friedel.

     

    I changed the package's ProtectionLevel of the package properties in BIDS to EncryptSesitiveWithPassword and gave a value to PackagePassword property.

     

    When deploying the package to SQL Server MSDB, it asked for the password and I provided the same password that I set above.

     

    Set up a SQL Agent Job with:

    a Step of type "SQL Server Integration Services Package"

    Picked the package from the SQL Server instance where I delpoyed.

    Clicked on the "Command Line" tab and it prompted for the package password. Entered it again. Once hit OK you should see a "/DECRYPT password" option in the generated command line.

    Saved the step and job.

     

    Now I am able to run this bob by right clicking th job and "Start Job"

     

    Saturday, January 12, 2008 1:50 PM
  • Thankx for your  valid information....
     This solution helped me a lot... Smile
    Wednesday, October 1, 2008 5:24 AM