none
Not all resources are showing up in Azure virtual network diagram or NetworkWatcher topology RRS feed

  • Question

  • Hi there,

    I'm setting up a simple demo environment in Azure.

    - Under the same vnet, two subnets were created, vlan-Production01 and vlan-DMZ01.

    - Each subnet has some VMs attached.

    - Each subnet has an NSG associated, with the 3 default rules.

    - No NIC NSG used.

    As shown in below pictures (oops, new user cant upload pix yet :(), when I generate the network diagram either in Virtual Network or NetworkWatcher, no VM nor NIC is shown under vlan-DMZ01. But all resources under vlan-Production01 are showing up correctly, e.g. VM, NIC, NSG.

    Any hint or suggestion is appreciated.


    Wednesday, September 18, 2019 8:29 AM

Answers

  • Hi, 

    Thank you for posting screen shots via email. 

    I see only one NIC present in the VNET “vnet-Production01” with Resource Group “rg-Production01” .

    The diagram will be displayed with the combination of Resource Group and the VNET. Hence it is showing as what you are seeing.

    Other NICs which you have mentioned belongs to different Resource Group.

    If you want those to be reflected in the same resource group, then move those NIC to the Resource Group “rg-Production01” .

    Regards, 

    Msrini

    Thursday, September 19, 2019 7:45 AM
    Moderator

All replies

  • Hi, 

    Can you drop an email to azcommunity@microsoft.com with the screenshots of your environment?

    I will take a look and revert. 

    Regards, 

    Msrini

    Wednesday, September 18, 2019 8:52 AM
    Moderator
  • Hi, 

    Thank you for posting screen shots via email. 

    I see only one NIC present in the VNET “vnet-Production01” with Resource Group “rg-Production01” .

    The diagram will be displayed with the combination of Resource Group and the VNET. Hence it is showing as what you are seeing.

    Other NICs which you have mentioned belongs to different Resource Group.

    If you want those to be reflected in the same resource group, then move those NIC to the Resource Group “rg-Production01” .

    Regards, 

    Msrini

    Thursday, September 19, 2019 7:45 AM
    Moderator