Installed Silverlight RC1 but still the browser show install silverlight Image

    General discussion

  • hi,

             I installed Silverlight RC1 but still the browser show install silverlight Image. i restarted the browser and the machine but still have this problem.. any suggestions are appreciated

    Tuesday, July 31, 2007 5:27 AM

All replies

  • Hi,

         This is probably you have not made changes to Silverlight.js and createSilverlight.js files.

    You wil find the SDK 1.0 here


    In the downloaded SDK you will find a help file which guves the dufferences between beta 1.0 and RC1.0


    Tuesday, July 31, 2007 7:47 AM
  • Hi Kiran...

    What if the user is simply a consumer of the SL and they're getting this?

    Yes I have a ton of SL on my website, but when I open my browser and browse out to a site with SL on it, there is NO Silverlight.js and createSilverlight.js on my machine that is related to browsing someone else's silverlight that I am responible for.

    All my pages on my site were fine as of Saturday morning, and I had no problem consuming them from this development machine. I rebooted the machine last night, and now I am stuck in a loop "needing to install RC1" ... and after it installs, it is telling me that I have a "newer" version installed.

    This has absolutely nothing to do with any silverlight.js or createsilverlight.js files because when I'm trying to install or run my site from my machine, I'm a consumer as is anyone else visiting my site.

    For me, the first thing that has to work is that I can hit a web site. If I can do that and have silverlight work, then I know the run-time is installed correctly. Then I can go forward with the SDK bits and start working locally on something, but until the run-time works, I'm stuck.

    So... any thoughts on how to resolve the "Newer version" problem or the problem of repeatedly getting the installation message would be greatly appreciated :)


    Tuesday, July 31, 2007 8:45 AM
  • hi

    i think i found a solution but not a professional one. install blend2 August preview create simple project with a text block. guess what it works. then re open it from visual studion and have fun its working now .

    Tuesday, July 31, 2007 8:59 AM
  • Hi WynApse,

    I am trying to put in by best comments on your post. I may or may not be correct.

    Even if the user is simply a consumer of the SL and has installed RC1.0 runtime they if he tries to visit a website which was developed targets beta 1.0,

    then we will asked to download beta 1.0 (for e.g.

    I mentioned silverlight.js or createsilverlight.js files because i assumed he migrated to RC1.0 runtime from Beta 1.0 and has taken care of "breaking changes".

    I tried to replicate your probelm on my production machine but was not successful totally.

    I visited your site I see the silverlight content fine.

    (I guess have u made changes to target RC1.0 instead of Beta1.0).

    I don't know if i was of any help to you or not but i feel it is nice interacting with you.

    Wednesday, August 01, 2007 7:21 AM
  • hi,

    I don't understand why when we install 1.0RC, we don't have silverlight.js and  createsilverlight.js in the installation folder for an easier integration with project develloped in 0.9 beta!!!

    Wednesday, August 01, 2007 9:05 AM
  • The 1.0 RC and 1.1 Alpha refresh are just the files you need to run the plugin and nothing more to keep downloads as small as possible. Anyone who wants to make Silverlight content should also download the SDKs which includes things you would need for developing Silverlight content.
    Wednesday, August 01, 2007 9:16 AM
  • Hi Kiran...

    We all seem to have chopped up these threads pretty good... :)

    Part of my difficulties yesterday in understanding some of the comments made by the MS folks was the fact that the Beta RC1 is wholly contained in the Alpha bits we got updated. As a developer, I should have just grabbed the Alpha run-time, and that would work for anyone's site, then get (for me) the RC SDK which I did.

    As it also turns out, it appears the original poster *was* running his own content, so the silverlight.js question was valid, although the way it was originally posted, I thought it might be a more "why can't I run this page" question.

    In case this one slipped under the radar, the old run-time timed out last night or this morning... so anybody that hasn't switched yet, has to now. Amazingly enough, I've gotten two emails so far today asking about "WPF/E" timing out... I'm not sure how anyone has been running that all this time :)

    I did update my site to RC1 last Friday, so it should all be good to go... I checked this morning and things seemed fine.

    I rebooted the box when I got home last night, and it came back up just fine, so I was unable to grab any metrics that would be of any use to anyone.

    Good 'chatting' with you too!


    Wednesday, August 01, 2007 11:58 AM
  • Hi WynApse,

                       Nice to hear things are working fine for you.Have great time.Let's digg the Silverlight further to find whatz in store for us?

    Thursday, August 02, 2007 2:05 AM
  • Hi All,

    I have a problem.

    I developed an SL project by Silverlight 1.1 Alpha.

    Then Silverlight 1.1 Alpha Refresh is released.

    I update my project with Silverlight.js file, Default.html.js file (which is come from 1.1 Alpha Refresh SDK) and Default.html file. And they can be visited succussfully under a machine which is installed 1.1 Alpha Refresh.

    But when I test it by using a machine which is not installed any Silverlight runtime file, when visit it, it will show Silverlight 1.0 RC icon. And after I click that icon and installed it. And when I tried to visit it again, it still show Silverlight 1.0 RC icon.

    I think it should show Silverlight 1.1 Alpha Refresh icon, not Silverlight 1.0 RC icon.

    Is it a problem in Silverlight.js file which is released in 1.1 Alpha Refresh SDK? or other problems.

    Thank you very much!

    Thursday, August 02, 2007 9:37 AM
  • I think it is MS problem in Silverlight.js file now.

    Because when you visit sample in quick starts which is in 1.1 Alpha Refresh version, it also show the logo of 1.0 RC icon. You can try following link in a machine which is not installed any silverlight run-time. And even you installed 1.0 RC by clicking the icon, that icon will show again.:

    Thursday, August 02, 2007 10:37 AM
  • Yes, I ran into that as well. Someone else posted a correct 1.1 alpha refresh version of Silverlight.js.

    You can snag it from my site here:

    That is one bit I'm surprised no one from MSFT has brought up anywhere.


    Thursday, August 02, 2007 5:15 PM
  • I just threw up a quick blog post with the correct .js file. You can see it here.


    Thursday, August 02, 2007 5:21 PM
  • I have the same problem:installed Silverlight RC1 but still the browser show install silverlight Image. I think that there is something wrong with SL RC1.

    Thursday, August 02, 2007 8:08 PM
  • Hi Pete,

    Thank you for tharing corrected Silverlight.js file.

    And is there some way to let MS guys aware this issue and fix it ASAP? I did not find a 'bug report' place to let them aware this issue.

    Thursday, August 02, 2007 8:13 PM
  • In order to avoid more problems than those solved, lets's just keep the situation, without modifying anything, and wait for the new version of Silverlight.


    Friday, August 03, 2007 11:01 AM
  • Perhaps, but I think folks may wnat to get something done between now and then :)

    If you back up your existing you can always copy it back and go throught the same install routine I outline in my blog, and be fine.


    Monday, August 06, 2007 11:56 AM
  • I would like to wait rather than doing any changes on my files. Who knows what is going to be wrong next time?

    Monday, August 06, 2007 8:20 PM
  • I would like to wait rather than doing any changes on my files. Who knows what is going to be wrong next time?

    That's wonderful. Thanks for sharing Smile


    Monday, August 06, 2007 8:31 PM
  • I really hope that Silverlight can imporve more. The present situation is : If you don't know javascript, you can do nothing. For example, I can use VB, but I can't even set a TIMER with VB language in a Silverlight Project. And the Silverlight, on principle, does not support other languages, such as Chinese. But, if Silverlight added these functions, the install file would be very large. So I doubt, in the future, is it still possible that we can finish installing it IN A FEW SECONDS?

    Monday, August 06, 2007 9:51 PM
  • What a mess.

    It all started as such a happy and easy journey. Now nothing works. Previously I followed a simple example and I just had one file silverlight.js now where is that file. The right one. Aparently I have to download the whole SDK 199 MB just to get this one js file! That cannot be right.



    Wednesday, August 08, 2007 8:49 AM
  • I got the silverlight.js file from Psychlist1972's blog site

    I hope he doesn't mind me posting that there.

    And removed the Sys from the begining of the Silverlight.createObject on the CreateSliverlight.js


    I even notice that if I right click on the silverlight canvas I gt access to the version information. Fantastic!


    Wednesday, August 08, 2007 9:29 AM
  • Also got this problem.

    First I uninstalled Silverlight and then installed SL 1.0 RC and SL1.1 visited some SL pages and found all good.

    Than - next day - and after restart i got the same old message to please install 1.0 RC.

    OK, I thought and did it again. Everything seems to work again ... until reboot.
    I've played this game several times.

    Than today I unstalled Silverlight, rebooted and did not installed SL 1.0 RC but only SL 1.1 Alpha.
    It seems that all SL1.0 apps still running even after rebooting my computer.

    Seems that this has been the fix for me.

    Thursday, August 09, 2007 3:11 PM
  •  This is retarded!

    Monday, August 13, 2007 5:13 AM
  •  This is retarded!


    I'm starting to see why people are fed up with buggy releases from Microsoft. I'm dumping Silverlight and staying with flash. No one should have to work this hard to get it to run properly. Clean install from and still can't view anything. Uninstalled twice and reinstalled and still doesn't work. What a joke. 

    Monday, August 13, 2007 5:45 AM