locked
Silverlight bug: Error code: 1001 RRS feed

  • Question

  • Recently Silverlight stopped working on my machine. In my development environment (Visual Studio 2012) I was getting the following vague error message:

    Line: 56
    Error: Unhandled Error in Silverlight Application
    Code: 1001   
    Category: RuntimeError      
    Message: 1001 An error has occurred.    
    MethodName:     

    Any websites I visited with Silverlight demos failed to load (only leaving a white space where the XAP should load)

    I tried installing Firefox, the same errors were happening there.

    I tried uninstalling and reinstalling.

    I tried uninstalling the Silverlight 5 SDK and Silverlight 4 SDK.

    None of this worked.

    Eventually after wasting a day searching up on this, I came across a Silverlight bug reported back in 2012. Apparently this is still a bug today in 2015 with Silverlight 5.

    Here are the details: https://connect.microsoft.com/VisualStudio/feedback/details/719317/silverlight-5-error-1001-font-filename-issue

    The fix was simple - I discovered a font file that had been recently installed. The font file name was Avenir.ttc but it contained versions of the font with & in the font name.

    I uninstalled this font (using Control panel > Fonts) and Silverlight started working immediately.

    If you ever have this issue, check your fonts directory!

    Thanks Microsoft!

    Wednesday, April 22, 2015 7:16 PM

Answers

  • Hi,

    Thanks for sharing this information to us, it will be very beneficial for other community members who have similar questions. From your description, you have encountered an issue that is similar with the Silverlight 5 Error 1001 bug, if you could reproduce this bug again, I would suggest you submit a new feedback with the detail steps to let the Silverlight team to know this issue.

    Best Regards,

    Jambor   


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 24, 2015 2:26 AM
    Moderator

All replies

  • Hi,

    Thanks for sharing this information to us, it will be very beneficial for other community members who have similar questions. From your description, you have encountered an issue that is similar with the Silverlight 5 Error 1001 bug, if you could reproduce this bug again, I would suggest you submit a new feedback with the detail steps to let the Silverlight team to know this issue.

    Best Regards,

    Jambor   


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 24, 2015 2:26 AM
    Moderator
  • Thank you for this post.  I have been dealing with blank silverlight tools for almost a year and finally found this.  Deleting Avenir from my PC immediately resolved the issue.  
    • Proposed as answer by Khaled hijjawi Tuesday, April 4, 2017 12:27 PM
    Monday, February 22, 2016 9:10 PM
  • Hi Aceofspades25,

    That was an incredible catch...thanks for sharing!

    Wednesday, June 1, 2016 4:30 PM
  • Thank you. This post saved me many hours of research. Removing the Avenir Font worked instantly for me.
    Monday, January 9, 2017 3:30 PM
  • 3 years later, this is still an issue - thank you very much!
    Thursday, June 14, 2018 9:40 PM