none
How Do I Keep SharePoint From Asking For My Password When Opening The Site / Hosted Document? RRS feed

  • Question

  • i have tried everything from this pretty complete guide: https://kb.intermedia.net/article/1668, without success.

    I have Sharepoint 2013; and am trying to map a document lib to network drive on Windows 10.

    Any tricks here for windows 10? i believe everything was working on windows 7.

    i can get on the sharepoint web site on IE without typing password.

    help pls!

     

    newbie to AS 2005

    Monday, September 9, 2019 9:17 PM

All replies

  • Hi heguangm,

    To troubleshoot the issue, you could check things below:

    1. Enable automatic logon with current username and password in IE.

    To enable automatic logon with current user name and password, go to Internet Explorer->navigate to Settings -> Internet Options->On the Security tab, click Custom Level->Under User Authentication, select Automatic logon with current user name and password.

    2. When you add the site into the trusted sites in IE, you could uncheck “Require server verification for all sites in this zone”.


    Note:

    If you're using File Explorer with Internet Explorer 11 or Microsoft Edge in SharePoint Classic experience, you should make sure you have the following fully qualified domain names (FQDN) in your trusted sites folder as below:

    <tenant>.sharepoint.com

     <tenant>-my.sharepoint.com

     <tenant>-files.sharepoint.com

     <tenant>-myfiles.sharepoint.com

    The <tenant> is your company's SharePoint name. For example, if you get to SharePoint via contoso.sharepoint.com, then replace <tenant> with Contoso.

    More reference:

    Using SharePoint in Windows 10.

    https://support.office.com/en-us/article/using-sharepoint-in-windows-10-a16bdaa4-73d6-45f8-897f-0a3cb8131763

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, September 10, 2019 2:20 AM
    Moderator
  • I am hosting my own sharepoint farm. I checked the IE 11 setting - exactly as you described.

    this just works if i open my site in IE. 

    i mapped one document library to a network drive: every time i logged off or restarted the machine, it prompts for password. That is my issue.


    newbie to AS 2005

    Tuesday, September 10, 2019 12:36 PM
  • Hi heguangm,

    To troubleshoot the issue, you could disable the loopback check and restart the server according to the article below.

    SharePoint 2013: Disable Loopback Check.

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    And you also could add the code below into the web.config located at C:\inetpub\wwwroot\wss\VirtualDirectories\80.

    <add verb="OPTIONS" allowed="false" />
    
    <add verb="PROPFIND" allowed="false" />


    There is a workaround, you could open an office document and you do not close the application completely but just the document. Then you could open other documents.

    More reference:

    Multiple Logon while open office Document from SharePoint.

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, September 11, 2019 9:38 AM
    Moderator
  • from this, all these solutions unlikely will work:

    https://support.microsoft.com/en-us/help/943280/prompt-for-credentials-when-you-access-webdav-based-fqdn-sites-in-wind

    so I changed to use a local server name.


    newbie to AS 2005

    Friday, September 13, 2019 3:05 PM
  • You need to provide the exact text of the responses you are experiencing when this problem occurs.  These responses help us more effectively and quickly diagnose the problem you are experiencing.
    Saturday, September 14, 2019 3:56 PM
  • Hi heguangm,

    Due to most solutions cannot work, if the issue does not have much impact, you could consider ignoring the issue.

    And it only prompts for password when you log off or restart the machine.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, September 16, 2019 8:58 AM
    Moderator

  • Hi heguangm,

    If the reply is helpful to you, you could mark the reply as answer. Thanks for your understanding.

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, September 18, 2019 9:21 AM
    Moderator