none
SSDT Install "Setup Failed" Recursion too deep; stack overflowed 0x800703E9. RRS feed

  • Question

  • I have windows 10 and newest visual studio version. I have tried rebooting to make sure I have as many resources as possible. I have 4g ram

    Just for the record this is something that has occurred in trying to do something I thought would be easy (3 days later now).   I have a bunch of reports in Visual Studio 2013 in a production system.  I have moved to Visual Studio 2017 and want to be able to work on them.  All I keep getting, no matter what i try and it's too much to even remember now, is Version 9 unknown errors when I try to preview or run the reports or load the rptproj file.  The google or microsoft search brings nothing definitive except load SSDT.  Fine but Visual Studio has a reporting services project extension that was loaded so why does that not recognize these????   Who knows, so while there is alot of ambiguity (at least it looks that way to me) about the relationship between SSDT and Visual Studio (why can't this be simple) I was finally told to load SSDT and that would add the features i needed to my Visual Studio.  Great, I'm on a roll...........except I am the very special case where that simple install doesn't seem to work. 

    this is DAYS of frustration and wasted time.   does it really need to be this hard!!!



    Thursday, March 8, 2018 12:03 AM

All replies

  • Reinstalling "Microsoft Reporting services Projects" in VS2017->Tools->Extensions and updates solved it for me
    Friday, March 16, 2018 1:38 PM
  • Hello Morten Vinther, I have the same problem, I did the suggested steps "Reinstall MSRS Projects" but it did not work for me, can you help me?
    Tuesday, May 29, 2018 3:01 PM
  • How I got past it:

    1 Uninstalled the Visual Studio extensions for Reporting Services (and Analysis Services) projects.  Note: remember to run VS as administrator to do the uninstall.

    2 Rebooted (just out of general principle.)

    3 Installed SSRS & SSAS extensions to VS using the SQL Server Data Tools download, (remembering to execute it as admin), adding them to my existing VS2017 rather than as separate installation, when prompted. 

    Obtained SSDT install from: https://docs.microsoft.com/en-us/sql/ssdt/download-sql-server-data-tools-ssdt?view=sql-server-2017

    The SSDT install instructions actually say to uninstall the existing extensions from VS, first.  Too bad the VS side doesn't mention this way, that I noticed.

    Given the SSDT install also includes SSIS, I presume this works for it, as well. I just don't use SSIS, currently, so I didn't bother installing it.

    • Proposed as answer by Sohail Hashmi Wednesday, September 5, 2018 10:37 AM
    Monday, June 25, 2018 3:51 PM
  • Hi John,

    Thanks for the above steps.

    It worked for me and should work for all.

    Wednesday, September 5, 2018 10:39 AM
  • Ensure you delete the .rsuser afterwards
    Wednesday, April 10, 2019 10:11 PM
  • Thank for this. It worked just as intended :-)

    Br

    Thomas Hvid

    Tuesday, July 2, 2019 8:57 AM
  • Thanks Sohail - worked for me too.

    For others trying this, note that after restarting the SSDT installer wouldn't start straight away because "devenv.exe" was running. I'm not sure what VS devenv.exe was doing in the background, probably some tidy-up tasks following the uninstall, but it closed itself down after a while and the SSDT installer was able to continue.

    Thursday, December 5, 2019 1:37 PM