none
Title Application pools recycle when memory limits are exceeded. ???

    Question

  • I just upgraded to MOSS 2010 and I get this error under health/monitor  issues

    Title Application pools recycle when memory limits are exceeded. 

    Severity 0 - Rule Execution Failure 

    Category Performance 

    Explanation The system cannot find the path specified.

     

    Remedy In the Internet Information Services Manager, uncheck any memory-based maximums set for the application pools named above. For more information about this rule, see "http://go.microsoft.com/fwlink/?LinkID=142692".

    Failing Servers GRETNAAPP64

     

    Failing Services SPWebService (WSS_Administration)

    Rule Settings View 

    Tuesday, November 30, 2010 7:52 PM

Answers

  • I have consistently seen this warning on SharePoint servers that have had the "Microsoft SharePoint Foundation Web Application" service stopped - usually, App servers.

    If this applies to you, nothing to be alarmed about (as is often the case with HA warnings). I think somehow the warning triggers because the app pools in question (used by content web applications) don't even exist on the app server(s) as we have stopped the Web Application service and thereby removed those app pools and IIS sites.

    HTH,

    Brian Lalancette
    Twitter: @brianlala
    Blog: http://spinsiders.com/brianlala


    Brian Lalancette Twitter: @brianlala Blog: http://spinsiders.com/brianlala
    Tuesday, November 01, 2011 8:45 PM
  • I hdad to reinstall my sharepoint enviroment for another issue and I no longer get this issue.


    How is this marked as an answer?!?!

    "reinstall your sharepoint" ? this is no answer and not a fix.

    Please unmark this as an answer.


    Regards, Shai Petel.
    Tuesday, May 10, 2011 6:52 PM
  • Hi,

     

    Based on my research, firstly, please check if SharePoint foundation web application service is provisioned on the Server, if not, start the SPF web application service on the Server, then see what’s going on.

     

    In addition, this issue is a known issue, which can be ignored or disabled, please check if you install SP1, if not, please install SP1, you can download SP1 from http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26623.

     

    Thanks,

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    Friday, November 11, 2011 2:15 AM
  • I had the same issue as everyone here after a move with application pools. The powershell code from Henrik fixed the issue for me.
    Tuesday, March 19, 2013 9:52 AM

All replies

  • Hi cpltek,

     

    Please take a look at the recycling conditions of the application pool. The steps are as follows:

     

    1.       Open IIS manager, In the Connections pane, expand the server name, and then click Application Pools.

    2.       In the Application Pools pane, select the application pool you want edit.

    3.       In the Actions pane, click Recycling...

    4.       Check if you set Memory based Maximums.

     

    For more information about Recycling Settings for an Application Pool <recycling>, please refer to the following article:

     

    http://www.iis.net/ConfigReference/system.applicationHost/applicationPools/add/recycling

     

    Hope this helps.

     

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    Tuesday, December 07, 2010 6:27 AM
  • Hi cpltek,
    Have you tried Rock's solution?
    Because I get the same warning in my environment, and if I look on the application pool (SharePoint web service root) no memory settings are checked...

    Regards,
    Leon

    Wednesday, December 08, 2010 10:36 AM
  •  I get the same warning in my environment. I checked every application pool - no memory based maximum settings are checked...
    Tuesday, January 04, 2011 4:14 PM
  • Any updates to this? I'm receiving the same warning... Thanks!
    Wednesday, January 05, 2011 3:16 PM
  • Same warning in my new production environment.  Checked all app pools - no memory based maximum settings are checked.

    Please help.

    Monday, January 10, 2011 9:45 PM
  • Add me to the list. I'm getting the same message and none of my Application Pools maximum settings are checked.
    Orange County District Attorney
    Thursday, February 03, 2011 3:58 PM
  • This solution did not work for me.  No memory-based maximums are set in IIS app pools and I still have the error in Health Analyzer.
    Thursday, February 03, 2011 4:33 PM
  • I am having the same message, I checked all the application pools and none of my application pools have the memory maximums set. I did click on Re Analyze but still having that warning message. Anything missing in the configuration?

     

    Monday, February 07, 2011 5:38 PM
  • Another one on the list,

    Same issue, warning, but no limits in recycling set,

    any updates?

    Tuesday, February 08, 2011 1:32 PM
  • Same here - have warning, but no memory limits set...
    Monday, February 14, 2011 1:06 PM
  • And another....


    Ricardo Vallecillo
    Monday, February 21, 2011 2:50 PM
  • I hdad to reinstall my sharepoint enviroment for another issue and I no longer get this issue.
    • Marked as answer by cpltek Wednesday, February 23, 2011 5:51 PM
    • Unmarked as answer by Rock Wang– MSFT Wednesday, May 11, 2011 1:24 AM
    Wednesday, February 23, 2011 5:51 PM
  • If you receive the ERROR message instead of a WARNING, check that the health rule can access your application pool. Check the servers to see if there is an app pool which is stopped. Start it and rerun the rule.
    • Proposed as answer by canthony74 Monday, November 07, 2011 4:35 PM
    Monday, April 11, 2011 2:34 PM
  • I hdad to reinstall my sharepoint enviroment for another issue and I no longer get this issue.


    How is this marked as an answer?!?!

    "reinstall your sharepoint" ? this is no answer and not a fix.

    Please unmark this as an answer.


    Regards, Shai Petel.
    Tuesday, May 10, 2011 6:52 PM
  • Add me to the list.

     

    Also I noted that after starting an App Pool that was stopped named "SharePoint Web Services Root" the severity shows:

     

    "0 - Rule Execution Failure"

    Tuesday, June 14, 2011 8:56 PM
  •  

    Same behaviour experienced here.

     

    Any known solution yet?

    Sunday, August 14, 2011 5:18 PM
  • I have consistently seen this warning on SharePoint servers that have had the "Microsoft SharePoint Foundation Web Application" service stopped - usually, App servers.

    If this applies to you, nothing to be alarmed about (as is often the case with HA warnings). I think somehow the warning triggers because the app pools in question (used by content web applications) don't even exist on the app server(s) as we have stopped the Web Application service and thereby removed those app pools and IIS sites.

    HTH,

    Brian Lalancette
    Twitter: @brianlala
    Blog: http://spinsiders.com/brianlala


    Brian Lalancette Twitter: @brianlala Blog: http://spinsiders.com/brianlala
    Tuesday, November 01, 2011 8:45 PM
  • I will confirm what BrianLala has said.  I've deployed several all-in-one farms and never saw this warning.  As soon as I deployed a tiered farm with a dedicated application server I received this warning.
    Tuesday, November 01, 2011 9:02 PM
  • This health rule checks each application pool in the SPWebService ContentService ApplicationPools collection.  If it can't find the Application Pool on the member server is it checking, it will fail and cause this Health Analyzer (HA) item (notice the application pool name(s) are blank in the message).

    You can determine the potentially missing Application Pool(s) with the following PowerShell:

    $contentService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
    $contentService.ApplicationPools | fl Name
    


    With this list of Application Pool names, open the IIS Manger on the server(s) reported in the Health Analyzer report, expand the Application Pools node and see if any are missing.

    I've seen this issue with multiple servers hosting CA where the first CA server had application pools for all of the web applications, but the other CA server(s) only hosted the CA and services application pools.  If the application pool should be on the server(s) reporting the error, try to let SharePoint create them for you (stop and start the "Microsoft SharePoint Foundation Web Application" service, for instance).  You can also disable this HA rule or create dummy application pools so the HA rule can find the application pool and not report this error.

    Kind Regards,

    Davis G. Trent

    Wednesday, November 02, 2011 10:13 PM
  • This post is the closest to an answer. 

    After checking the failing servers in the message I traced the rule settings back and figured out that the rule is really an "ALL or Nothing" kind of rule.  So if you have your services isolated like a 4 node farm with 2 web, 1 app, and 1 server, the rule will show an error for the servers that you have disabled the service in question on. 

    This seems like a bug to me that microsoft should fix.   I should be able to tell this rule only run on servers that the service is enabled on.  Not all servers run the same services.  But they create a rule that will show errors because it looks for the same services on all of your systems.

    Monday, November 07, 2011 4:38 PM
  • Hi,

     

    Based on my research, firstly, please check if SharePoint foundation web application service is provisioned on the Server, if not, start the SPF web application service on the Server, then see what’s going on.

     

    In addition, this issue is a known issue, which can be ignored or disabled, please check if you install SP1, if not, please install SP1, you can download SP1 from http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=26623.

     

    Thanks,

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    Friday, November 11, 2011 2:15 AM
  • Hello Rock,

      This HA report is usually triggered for member servers that shouldn't host the SPF app pools.  Ignoring or disabling this rule is probably the most correct thing to do.

      Unfortunately, SP1 does not fix this issue.

    Kind Regards,

    Davis G. Trent

    Friday, November 11, 2011 4:43 AM
  • First i checked Rock Wang–MSFT answer about the recycling settings on my application pools in IIS, but non of the application pool had any memory based recycling limits

    I used SPautoinstaller when I installed sharepoint 2013: We have a policy that says that i can only use one application pool on the solution which I am now installing. In the SPautoinstaller script i made 2 web applications on the same application pool, this gave me an error because the application pool already existed after the first web application was created earlier in the script. I solved this by making a temp application pool, then changed the site in IIS to the main application pool and then deleted the temp pool. 

    After that change I got the "Application pools recycle when memory limits are exceeded." warning in the "Health analyzer report" under central admin -> monitoring -> review problems and solutions

    The following fix will also work with Sharepoint 2010, with or without the use of spautoinstaller in the initial installation:

    Following Davis Trent answer I found that one site was still connected to the old temp application pool, after running the following:

    $contentService=[Microsoft.SharePoint.Administration.SPWebService]::ContentService
    #Get the list containing the applications pools and the ID:
    $contentService.ApplicationPools

    #remove the temp application pool by ID:

    $contentService.ApplicationPools.Remove("<insert temp application pool ID>")

    I got an error saying: 
    Exception calling "Remove" with "1" argument(s): "An object in the SharePoint administrative framework, "SPApplicationPool Name=tempHost", could not be deleted because other objects depend on it.  Update all of these dependants to point to null or different objects and retry this operation.  The dependent objects are as follows: SPWebApplication Name=TEST Host

    I ran the following commands to update the values in SPwebapplication:

    $t = Get-SPWebApplication "<insert url or name of temp web application>"
    $t.ApplicationPool.id = "<insert the application pool id of the main web application>"
    $t.ApplicationPool.name = "<insert the application pool name of the main web application>"
    $t.Update()
    iisreset

    Now I was able to run the following command:

    $contentService.ApplicationPools.Remove("<insert temp application pool ID>")

    Central admin -> monitoring -> review problems and solutions -> rechecked the "Title Application pools recycle when memory limits are exceeded. " warning and it was gone :)

    Hope this helps someone :)


    Monday, January 21, 2013 9:29 AM
  • I had the same issue as everyone here after a move with application pools. The powershell code from Henrik fixed the issue for me.
    Tuesday, March 19, 2013 9:52 AM
  • That one needs to be stopped, there's no need to start it.

    MCTS Web Application Development, SharePoint enthousiast.

    Monday, March 24, 2014 1:51 PM