Sharepoint 2013 SPDistributedCacheService & AppFabricCachingService Cluster, Host, and Service problems RRS feed

  • Question

  • We have a Sharepoint 2013 farm with 1 APP/WFE server and 1 WFE servers. We added another WFE server (Server X), and removed it the next day. Server X became the main cache host, before removal. Without setting the APP/WFE server as the new Cluster owner we removed Server X.

    The Distributed Cluster Service stopped working, and with whatever we tried from all the forums, nothing worked.

    We get all sorts of errors:
    cacheHostInfo is null, No hosts present in the cluster, etc...

    On the APP/WFE, I deleted the Service Instance, and Recreate with Powershell > "Add-SPDistributedCacheServiceInstance". When I do a CacheHostInfoCollection I get this:

    CacheHostsInfoCollection    : {}
    Name                        : SPDistributedCacheCluster_a0cf3c42-af25-4c95-bc14-47d744f52ffd
    TypeName                    : Microsoft.SharePoint.DistributedCaching.Utilities.SPDistributedCacheClusterInfo
    DisplayName                 : SPDistributedCacheCluster_a0cf3c42-af25-4c95-bc14-47d744f52ffd
    Id                          : 54d37a05-5a86-4114-b900-36b59b76489b
    Status                      : Online
    Parent                      : SPDistributedCacheClusterInfoManager Name=ObjSPDistributedCacheClusterManagerKey
    Version                     : 3063
    Properties                  : {}
    Farm                        : SPFarm Name=spSharePointConfigdatabaseName
    UpgradedPersistedProperties : {}

    So in my opinion I configured the APP/WFE server to be a Cache Host, however if I try to start the server service in Central Admin, I get the "cacheHostInfo is null" error with the following ULS log.

    SharePoint Foundation DistributedCache Unexpected A failure occurred in SPDistributedCacheServiceInstance::Provision. cacheHostInfo is null for host 'APP/WFE'
    SharePoint Foundation DistributedCache Unexpected A failure occurred SPDistributedCacheServiceInstance::Provision() , Exception 'System.InvalidOperationException: cacheHostInfo is null at Microsoft.SharePoint.DistributedCaching.Utilities.SPDistributedCacheServiceInstance.Provision()'
    SharePoint Foundation Topology Critical An attempt to start/stop instance  of service Distributed Cache on server 'APP/WFE' did not succeed.  Re-run the action via UI or command line on the specified server. Additional information is below.  cacheHostInfo is null

    When I Export-CacheClusterConfig and read through the file i see gaps in the XML as well as old information from the addition and removal of Server X. I know I can use Import-CacheClusterConfig but the provider type as well as the connection string is missing in the exported file, and the account associated is wrong.

    Added Server X to the farm again, and tried to configure the SPDistributedCacheService but to no avail. - did not help.

    Any help or troubleshooting tips will do thanks 


    Thursday, October 10, 2013 8:54 AM


All replies