locked
Sharepoint 2010 Approval Workflow "Open this task" link not functioning RRS feed

  • Question

  • When I am clicking on "Open this task" link in outlook 2010 i am getting error as "Access to the floowing form required". Please help me out to resolve the issue..

     

    Thanks,

    Basavaiah 

     

     

    Monday, August 23, 2010 7:11 AM

Answers

All replies

  • Does your account have permissions to the task list?  The workflow should assign permissions to the task itself automatically.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, August 23, 2010 7:25 AM
  • Yes I am in the Type Group with Full Control... 

     

     

    Monday, August 23, 2010 7:43 AM
  • Type Group?
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, August 23, 2010 7:48 AM
  • My Site name is Called "Home".Under Home Owners group i have added with Full Control....
    Monday, August 23, 2010 7:52 AM
  • Yes, but do you have access to the actual task?  It doesn't really matter what the site permissions are, because permissions in SharePoint are granular down to the item.  You have to look at the permissions of the actual task to verify its permissions.

    You said your error was, "Access to the floowing form required."  Did you mean "flowing" or "following"?


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, August 23, 2010 7:58 AM
  • Hi,

    I have Cteated a sample workflow using Start Approval Process Action.When I am publishing the workflow, one InfoPath form generating automatically(Menu) to complete the task by clicking on Approve /Reject.

    I am getting mail as Task assigned to you when i ran the workflow. In Outlook 2007, If i click on Edit this task link its working fine and I am able to complete the task

    In outlook 2010, If i click on Open this task i am getting error as "Outlook cannot open new form, To open the file, access to the following form template is required: Displaying URL.

    My problem is same thing opening in outllok 2007 but getting error in outlook 2010.If it is problem with Permissions, where i can give permissions to the form..(This form is generated automatically when i published the workflow using Staart Approval action) Please help me in this..

    Thanks

    Monday, August 23, 2010 8:12 AM
  • So you're logged in with the same user to two different versions of Outlook, and it works for 2007 but not for 2010?  I don't see how that could be possible.  You're sure you aren't leaving out information?  I still am wanting you to check the permissions of the actual task that is assigned to you.  I asked you to do that twice, but then you asked me where you can give permissions to the form...the same place where I want you to check the task permissions.  Look at the actual permissions of the task.  Also, if the error message displayed the URL of the form, then go find it with the same user account that is logged into Outlook 2010.  See if that user account can see the form directly.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, August 23, 2010 8:15 AM
  • Hi,

    I had seen the task permissions my user account is available.My question is if i don't have permissions it will not work with 2007.Its working with Outlook 2007 but i have problem with Outlook 2010.

    I think Outlook 2010 has more secured than 2007. Do I need to set any other configurations aprat from permissions..

     

    Thanks,

    Basavaiah

    Monday, August 23, 2010 9:20 AM
  •  

    I've got a user experiencing a similar issue.  The Open this Task does not work from Outlook (64bit) or Word (64bit).  This user was able to open workflow tasks last week. We're using SharePoint 2010.

    Other users are not having issues.

    I'm wondering if any patches may have caused this?

    Tuesday, August 24, 2010 4:01 PM
  • Hi Guys,

    Please respond as soon as possible if you know the solution it will helpful for me to release the project.

     

    Wednesday, August 25, 2010 10:15 AM
  • Hi,

    I had the same problem and just removed the "open this task"-button. Now the user gets an email with a link to the task he has to edit.

    That is working great. Just in case, somebody needs a quick workaround.

    Cheers

    Thursday, October 14, 2010 1:09 PM
  • Hi,

     

    Same Issue. How did you manage to remove  "open this task button"? kindly explain.

    Friday, October 15, 2010 2:01 AM
  • In the GPO editor, navigate to User Configuration -> Administrative Templates -> Microsoft Outlook 2010 -> Miscellaneous. Enable the "Do not display "Open this task" button for workflow task"  You will have to refresh the policy on the workstation for this to take effect (gpupdate /force) or simply log off and back on. 
    JustinS
    Tuesday, October 19, 2010 4:54 PM
  • Hi,

       Can you tell me the manual URL string you created in the email to link the user to their particular task?  Thanks!


    Chia Yang
    Thursday, October 21, 2010 8:24 PM
  • I am getting the exact same problem and while you don't see how it's an issue, it is.  Outlook 2010 is having a problem using the open this task button, while Outlook 2007 does not.  Removing the button is problematic as the link does not take you directly to the task and every extra click somone has to do means a loss of productivity. Here is the error I get from Outlook 2010.

    Outlook cannot open a new form. The form contains schema validation errors.

    "Element '{http://schemas.microsoft.com/office/infopath/2009/WSSList/dataFields}Author' is unexpected according to content model of parent element '{http://schemas.microsoft.com/office/infopath/2009/WSSList/dataFields}SharePointListItem_RW'.
    Expecting: {http://schemas.microsoft.com/office/infopath/2009/WSSList/dataFields}FieldName_Comments, {http://schemas.microsoft.com/offi....

     

    Monday, December 20, 2010 4:02 PM
  • I have the same issue, and I am a farm/site collection administrator.  I created the list and created the approval workflow.  This works for my Outlook 2007 client but not for my Outlook 2010 client.  The odd thing is that it works for another co-worker who is using Outlook 2010, and it works for me if I log into his desktop.

     

    Can someone suggest what files/configurations I should compare between the two 2010 clients?

     

    Wednesday, December 29, 2010 11:46 PM
  • Yes, I can confirm that as well.

    There are 3 difference scenarios in Office 2010, not clear to me what's the trigger.

    1, button does work.

    2, button does not work at all.

    3, button works, but user is prompted with error about Infopath form.

    Anyway there is something wrong with this functionality.

    Tomas


    Tomas Paulas MCP,MCSA,MCSA-Messaging
    Tuesday, January 11, 2011 10:47 AM
  • The fix I found is here....

    http://forums.spybot.info/showthread.php?t=18600

    Once you delete this key

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{00000000-0000-0000-0000-000000000000}

    All works fine.

     

    • Proposed as answer by dwpmartin Monday, January 17, 2011 10:29 PM
    • Marked as answer by Pengyu Zhao Friday, May 25, 2012 8:07 AM
    Monday, January 17, 2011 10:28 PM
  • IT WORKS !!!!

    Cool, thank you.

    Tomas


    Tomas Paulas MCP,MCSA,MCSA-Messaging
    Monday, January 17, 2011 11:07 PM
  • Unfortunately the regedit ActiveX Compatibility GUID wasn't present so I couldn't delete it.  I kept searching and tried this:

    

     Follow these steps:

    a. Open Internet Explorer.

    b. Click “Tools” and “Internet Options.”

    c. Click the “Advanced” tab.

    d. Scroll down to “Security.”

    e. Un-check “Do not save encrypted pages to disk.”

    f. Click “Apply” and “OK.”

    Restart Internet Explorer and verify if the issue persists.

    Pasted from

    http://answers.microsoft.com/en-us/ie/forum/ie9-windows_7/i-cannot-download-files-in-internet-explorer-9/94903994-3888-49bd-b6a0-3cc3d5d7bfa3

    Not sure why but if I uncheck the box it works and rechecking breaks it.  Perhaps IE downloads the files on behalf of Outlook and Word, but Outlook can't get to them if the files aren't saved in cache by IE.  Our SharePoint site is secured by an SSL/TLS certificate. 

    • Proposed as answer by AnikkeBukowski Wednesday, December 23, 2015 2:11 AM
    Monday, August 27, 2012 10:44 PM
  • This cannot be applied on all users machines.  We need a solution that does not involve Registry edits!


    • Edited by CrjangelFG Monday, October 14, 2013 1:36 PM
    Monday, October 14, 2013 1:36 PM
  • Unfortunately the “Do not save encrypted pages to disk.” wasn't checked so I couldn't uncheck it. =(
    Wednesday, September 3, 2014 5:33 PM
  • Thanks.  Fixed the problem for me in Win 7 64bit running Outlook 2013 and IE 11.

    Neil

    Tuesday, January 6, 2015 11:06 PM
  • Did you ever find a solution to this? I am stuck where you were. 
    Thursday, October 8, 2015 7:38 AM
  • I have yet to find an answer for this either. It happens on maybe 10% of my users. SharePoint enterprise 2013 and office 2013. Anyone find an answer to this yet?
    Tuesday, August 23, 2016 9:41 PM